Updated Mod Rules
News
/
Updated Mod Rules
Posted 3 months ago by

Updated Mod Rules:

• 1.14-1.16.5: Voyager 1.0.1 is now allowed. This update legalizes the implementation of the mod which was used in Fabric API.

• 1.3.x: No-Paus 1.0.1 is now allowed. This mod backports the Pause on Lost Focus feature for macros.

• 1.3.1-1.5.2: StatsPerWorld 1.2 is now allowed. This fixes an unintentional icompatiblity declaration with 1.5.1-1.5.2.

• 1.3.1+: Force-Port 1.2.0 is now allowed. This update essentially removes the maximum player limit, before the mod made it 20, now it is the integer limit.

• 1.3.1-1.12.2: Dynamic FPS 1.1.0 is now allowed. This update is just an expansion to the supported versions.

• 1.3.1-1.13.2: Legacy MotioNO is now allowed. A backport of MotioNO to Legacy Fabric. It still requires permission alongside regular MotioNO.

• 1.14-1.16.1: MotioNO 1.0.2 is now allowed. This version of MotioNO supports 1.14.x as well as putting 1.15.x and 1.16.1 support in the same jar. It also removes unnecessary modmenu support to achieve this.

• 1.14+: SleepBackground 3.9 is now allowed. This update brings a setting to lower the framerate cap on the loading screen for faster resetting.

• 1.3.1-1.5.2, 1.13.2, 1.14.x, 1.18+: Set Spawn is now allowed for SSG only. With these ports, Set Spawn now has full coverage of Minecraft versions for which Fabric or Legacy Fabric intermediaries exist.

• 1.3.1+: State Output 1.1.5 is now allowed. This mod extracts the state outputting feature in WorldPreview 3.0.0 to 4.0.2 to its own mod so it can support more versions than WorldPreview does, and also categories that do not use WorldPreview such as SSG.

• 1.18.1, 1.18.2, & 1.19+: Chunkcacher is now allowed for SSG only. This update ports Chunkcacher to the newest versions of Minecraft and seperates the 1.18.x ports into a 1.18.1 and 1.18.2 version to fix a mixin crash on 1.18.1.

• 1.3.1-1.13.2: OptiFabric 2.3.2 is now allowed. This update expands the versions OptiFabric supports to all Legacy Fabric versions, and combined all the builds into a single jar.

• 1.14.x: OptiFabric Origins 2.0.1 is now allowed. This update adds support for Fabric Loader 0.15+.

• 1.14: Starlight is now allowed. This update is a port to Minecraft 1.14.2-1.14.4.

• 1.16.1: Sodium 2.0.2 is now allowed. This update has no user-facing changes, but backports a small fix from upstream Sodium for compatibility with multiple world renderers and a fix for the vanilla menu not opening in edge cases.

• 1.15.2: Sodium 1.1.1 is now allowed. This update replaces the Sodium menu with the vanilla menu, as was done with 1.16.1, and backports the other 1.16.1 changes.

• 1.16.1: Sodium Mac 3.0.1 is now allowed. This update ports the changes to the upstream 1.16.1 branch.

• 1.15.2, 1.16.1: WorldPreview 5.0.0 is now allowed. This update removes the state output feature and lets the mod interact with the State Output mod instead to output a previewing state.

• 1.16.1+: FastReset 1.4.2 is now allowed. This update supresses the 'IllegalStateException' and 'ConcurrentModificationException' the mod would sometimes print when quitting a world and ports the mod to the latest versions of Minecraft.

• 1.17.1: Starlight 1.0.1 is now allowed. This update backports the rare structure placement crashfix that was previously backported to 1.16.x

• 1.6.4, 1.7.2-1.7.4, 1.9.4-1.20.4: Atum 1.2.1 is now allowed. This update ports the mod to 1.6.4, 1.7.2, 1.7.4, 1.19.4, & 1.20.4 as well as fixing various bugs, such as the "ghost pie" after resetting with WorldPreview, a 'StackOverflow' when continuously resetting on preview with WorldPreview, 1.13.2 atum not launching, Legacy Fabric versions not naming worlds correctly leading to a crash when the filepath become too long, the ability to disable structures not working in 1.19.2, freezes in 1.9.4-1.12.2 atum when resetting immediately following a dimension load, setting the hotkey triggering a reset, the loading screen showing the seed on dimension changes in pre 1.13, and various consistency fixes in translations.

While none of these mods require Fabric Loader 0.15+ except for OptiFabric Origins 2.0.1 for 1.14.x (and in that case you can just use the previous release of 1.0.1 for pre-0.15 support), they are all compatible with the update and most mod updates going forwards will start making 0.15+ a hard dependency. Updated Legacy Fabric MultiMC instances will be put out ASAP. Please be sure to update your instances!

Because of the migration to legal-mods, the old tools currently do not work with these updates. For now you can use https://mods.tildejustin.dev as a replacement for the MCSRMods website and https://github.com/tildejustin/modcheck/releases for a working ModCheck.

Game stats
Followers
41,255
Runs
21,495
Players
7,670
Latest news
Updated Legal Mods
  • (1.20-1.20.6) StandardSettings 1.2.4 has been ported to 1.20-1.20.6.
  • (1.19+) Planifolia 1.0.1 for 1.19+: supports launching without Sodium for gamma 5 by itself and fixes a visual desync of the entity culling option when it is set via StandardSettings
  • **(1.19+)
11 days ago