Error when using setspawnmod
Minecraft: Java Edition Forums
Error when using setspawnmod
South Korea

Wow. Never thought I'd be asking so many questions, but I've returned to MCSR and have things changed.

I get the following error when using setspawnmod: Uncaught exception in thread "main" java.lang.RuntimeException: Error creating Mixin config setspawnmod.mixins.json for mod setspawnmod at net.fabricmc.loader.impl.launch.FabricMixinBootstrap.init( at net.fabricmc.loader.impl.launch.knot.Knot.init( at net.fabricmc.loader.impl.launch.knot.Knot.launch( at net.fabricmc.loader.impl.launch.knot.KnotClient.main( Caused by: org.spongepowered.asm.launch.MixinInitialisationError: Error initialising mixin config setspawnmod.mixins.json at org.spongepowered.asm.mixin.transformer.Config.create( at org.spongepowered.asm.mixin.Mixins.createConfiguration( at org.spongepowered.asm.mixin.Mixins.addConfiguration( at net.fabricmc.loader.impl.launch.FabricMixinBootstrap.init( ... 3 more Caused by: java.lang.IllegalArgumentException: The requested compatibility level JAVA_17 could not be set. Level is not supported by the active JRE or ASM version (Java 1.8, ASM 9.5 (ASM10_EXPERIMENTAL)) at org.spongepowered.asm.mixin.MixinEnvironment.setCompatibilityLevel( at org.spongepowered.asm.mixin.transformer.MixinConfig.initCompatibilityLevel( at org.spongepowered.asm.mixin.transformer.MixinConfig.postInit( at org.spongepowered.asm.mixin.transformer.MixinConfig.onLoad( at org.spongepowered.asm.mixin.transformer.MixinConfig.create( at org.spongepowered.asm.mixin.transformer.Config.create( ... 6 more

Chicago, IL, USA

Update Java

You can install the latest version of Java here (download the .msi file if you're on Windows, download the .pkg file if you're on Mac) To get Minecraft to use that version of Java,

  • If you're using MultiMC or Prism: Go to Settings > Java > Auto-detect and select the latest version you have (not necessarily the starred version). If the one you downloaded doesn't show up, click Refresh on the bottom left in the Auto-detect menu.
  • On Prism, make sure to disable the Java compatibility check in Settings > Java
  • If you're using the official Minecraft launcher: Go to Installations > "..." for the installation you're using > Edit > More options, click the "Browse" button for Java executable and navigate to C: > Program Files > Eclipse Adoptium > jdk-x.x.x.x > bin > javaw.exe. Select the javaw.exe file. You will then need to delete JavaCheck.jar.
Edited by the author 3 months ago
Benbenq99 likes this
Victoria, Australia

Thanks Olock5,

I tried to use the vanilla launcher but it wouldn't work since for some reason, as there was a javaw file on the JDK but it was an app and not a .exe

I then tried out using multimc for the first time but needed to install the latest speedrunIGT for it to work, and finally the set spawn mod works!

In conclusion for those that want set spawn to work, just use multiMC because it has a smart detection to use the correct java version (I used java 20).

CriticaI likes this