Forums  /  Resident Evil 2 (2019)  /  How to limit your frame-rate
  FirkraagFirkraag
(edited: )

Nvidia:
1. Download Nvidia Profile Inspector, this tool shows you an expanded list of settings included in your Nvidia drivers @ https://github.com/Orbmu2k/nvidiaProfileInspector/releases

2. Make a profile for RE:2 and limit the fps like this:

Note: If the 120 fps setting ends up giving you a lock higher than that just lower it a few steps. The advantage of Inspector is that once you set your limit you will not have to run the app again and neither will it have to be on during play.

AMD:
1. Download the latest Rivatuner Statistics Server @ https://www.guru3d.com/files-details/rtss-rivatuner-statistics-server-download.html

2. Make a profile for RE:2 and limit the fps like this:

Note: This app will have to be running while you play. It also works for Nvidia.

In-game Settings:
V-Sync, if you're on a 60hz monitor turn this off or you'll be locked to 60fps. If you got a 120hz monitor you can skip the above tools and just turn v-sync on to lock it to 120fps.
Framerate, keep this at variable if you're running 120/variable categories and set it to 60 for the 60fps one.

blargien1blargien1, AlmightyMandalsAlmightyMandals and 5 others like this. 
  pentalekspentaleks

Just a quick note:

Nvidia Profile Inspector adds more input lag (sometimes 4 frames depending on the game). Rivatuner adds 1 frame of input lag.

 
  RoyzogaRoyzoga
(edited: )

So, I ran into a bit of an issue with this. I have the frame rate variable thing, but for some reason when I capture through OBS it shows up as a black box / capture. I can get it to show up with Game and Display capture, but then the frame rate doesn't show up, so I'm a bit confused. Also wasn't sure if the frame rate was supposed to display all the way at 120 since even after using the Nvidia based program, steam still shows it capping at 60FPS. Anyway, thanks in advance!

EDIT: I got the Frame rate to push up to 120 FPS and am able to do the Birkin and Tyrant fights, but the previous issue still stands sadly. I'll keep looking into it in the mean time!

 
  BrescazBrescaz
(edited: )

For some reason it doesn't work at all. Tried to change the frame rate limiter mode too, same. Any solution ?

EDIT : Solved

 
  RoyzogaRoyzoga

Okay, so disregard my post entirely now, ahaha. Someone on the Discord pointed out that Game Capture in OBS has an option to have things like Steam Overlay display over top of it in the properties section, or when you're first adding it. In terms of the Frame Limiter thing, I actually ran into that too, but forgot that V-Sync was on, so after I disabled that my frame rate capped properly at 120 instead of 60. Hopefully this helps someone else!

 
  BrescazBrescaz

So for those who frame limiter don't work.
Check in your nvidia control pannel (in 3d section) in Program Settings if you already have RE2.

Delete it. It will overwrite Nvidia inspector if you have it.

KillinInstinctKillinInstinct and CursedToastCursedToast like this. 
  PsarthexPsarthex

https://puu.sh/CM6KJ/cded054168.png

FYI:

Video doesn't show it but the V2 thing is just below the frame rate limiter (at least on my Profile Inspector)

I had really shitty fps drops (down to 40fps on lowest settings/resolution) without the V2 mode, couldn't get 120 fps even with a decent rig (1080gtx/Ryzen1K7x) but adjusting the Frame rate limiter mode fixed it -at least without streaming- .

Hope it'll be useful to some

dteqdteq, ffleretffleret and ElevalEleval like this. 
  ResidentJack96ResidentJack96

sometimes my fps goes to 121 when i capped it too 120, only happens every now and again, that wouldnt void the run would it?

dteqdteq, PuddinghousePuddinghouse and 2 others like this. 
  madmilldromadmilldro

I have a 144hz monitor. My fps is usually below 120 fps anyways. I submitted a 51:51 with variable fps and 144 hz as the refresh rate but no vsync.

 
  ZGotenZGoten
(edited: )

I would like to know about ResidenJack96's question as well. I'm kind of tempted to lmit the framerate to like 118 just because occasionally it goes 1 or 2 fps over the cap. This is with Rivatuner.

PuddinghousePuddinghouse likes this. 
  ElStickmanElStickman

I got the problem that it doesn't limit my FPS

 
  Jadusable2Jadusable2
(edited: )

So i'm having a crashing issue when I try to run 120 fps. I took a screenshot and hope that someone knows whats going on. I have googled it and haven't found anything yet.

https://imgur.com/a/G4gvuU5

EDIT: I forgot to mention that it crashes at random. I crashed getting the unicorn medallion and picking up the grenade in the bus on Claire 1st.

 
  bearlolbearlol

@Jadusable My best answer for you?
If this only happens at 120 FPS, then lock at 60 FPS and play on that.

 
  Jadusable2Jadusable2

I forgot to mention that I was streaming at the time, so many that was the issue? I played more that night at 120 fps and it ran just fine.

 
  nibnonibno

framrate is capped is 30 in this game