FDS glitch not glitching
1 year ago
Alberta, Canada

So, I'm just starting to learn FDS any% but for whatever reason, I can't get the glitch to cooperate. I have tried about a half dozen different roms and none of them produce anything different than what happens in this clip

I am running on an Everdrive N8, not Pro. Does anyone know what I am doing wrong, or if there is a specific rom that should be used?


Hey, so according to @Sathdresh this is exactly what happens on the n8 pro. It never worked on the n8 pro only the original n8.

So this seems to be an everdrive issue.

What firmware version are you running on your n8? I was looking through the firmware changelog and v1.24 (released in october 2020) had some fixes for fds. Possibly this broke something?

Try firmware v1.20. That's the one I'm using and it works for sure on that one.


Alberta, Canada

I believe I'm on v1.23, but I will try out 1.20. I'll update if I figure it out so if someone else has this question in the future, the answer will be here.

Alberta, Canada

Well, for whatever reason, I had to go back to version 1.16 to get it to work, but it is working for me now. I will probably finish learning and start grinding a bit after work today.

Canight, Sathdresh, and xenkaroshi like this
Game stats
Latest threads