Misc Glitches Thread
2 years ago
San Francisco, CA, USA

I just need a place to dump glitches I find. Feel free to post here too.

Here is a playlist where I'm putting all of my SFA glitch videos ()

===============================

If we can figure out how to get OOB with Mammoth #1, we can save time on the TAS route by skipping cannon / Blow Horn. I was able to do it with speed hack AR codes, but I have not been able to do it normally.

Edit: This is also possible! See post #10

===============================

I've also been attempting to find a DIM #1 => DIM #2 sequence break. Nothing promising yet.

Edit: I figured it out! See post #7 below.

It may be possible if we can: A ) Avoid losing tricky during DIM #1, OR have rescued him from prison. We need him for Galdon [1]. B ) Hit the DIM Link map loading triggers C ) Hit the DIM #2 loading triggers D ) Drop down from the cutscene area. Requires avoiding the cutscene, or have previously triggered it (ie with an ESW setup), and being OOB. [2]

[1] Interestingly, the game will give you Tricky for the Galdon fight even if he is still imprisoned. However, the game will soft-lock in the cutscenes after defeating Galdon. Edit: My understanding was wrong. Triggering the speeder end cutscene without rescuing Tricky causes the soft-lock. [2] We can pre-trigger the cutscene by freeing tricky and ESW'ing back to mammoth post #3.

Here is an attempt that satisfies A/B, but not C/D. Builds on one of BvqR's videos (AR code used for speedhack again).

Ways to dismount:

  • Feeding Tricky a GrubTub
  • Item discovery
  • Colliding with a climbable ledge. This is possible in DIM #1 outside the second cog room on the wood platforms (note: Fox cannot hit anything with his staff if dismounted this way)
  • Interacting with an object, ie using a cannon.
  • Triggering a cutscene.

Only the mammoth can hit loading triggers. It is possible to unload the mammoth we are riding / detached from. Unloading the mount while riding it = crash. Triggering a dismount while the mount is unloaded = crash.

Edited by the author 2 years ago
San Francisco, CA, USA

We can get some interesting effects from erasing a file after hitting an ESW checkpoint.

Even stranger if we punch in a cheat code after erasing a file and making a new one:

Nothing useful in a route, and seems more likely to cause negative effects than positive ones.

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

Using a cannon while mounted:

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

By ESW'ing to the CRF gate, we can obtain SS2 multiple times. Has no apparent ingame effect.

This allows us to get captured and put in jail again (but we keep staff), then walk directly to the SS2 race.

If we try to turn in SS2 again, the game plays the cutscene when we enter the Spell Stone room, but does not take the SpellStone from our inventory.

Normally when revisiting a SpellStone (only possible via hacks, gates are closed otherwise), the SpellStone is gone.

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

Strangely, collecting SS2 twice makes causes the "You already collected the SpellStone" dialog to show in orbit for both Walled City and Dragon Rock.

Even though I get this dialog, I can still collect SS3/SS4 without any issues.

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

If we use the mammoth to get to the speeder bike, Tricky will appear on the track. We can then do a GrubTub dismount!

I can't find any use yet. The camera is tedious to work with.

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

A sequence break is possible! By carefully navigating while dismounted from the speeder bike, we can bypass the cutscene at the end of the DIM Link map, and skip to the Belina cutscene / barrel section.

Steps:

  1. Go to mammoth post #3, get OOB.
  2. Avoid any triggers that unload the mammoth, and make your way to the speeder bike.
  3. Hit the loading trigger by the breakable mammoth door to load the speeder.
  4. Dismount the mammoth by feeding Tricky a GrubTub. This can be done at the end of the covered part of the tunnel.
  5. Mount the speeder bike, and go to the end of the outdoor section
  6. Dismount the speeder bike by feeding Tricky a GrubTub
  7. Do extremely painful speeder bike / Fox dual navigation to the end of the track. 8 ) Move the speeder passed the cutscene trigger, but keep Fox behind it
  8. Press A. Fox will warp to the speeder, bypassing the cutscene trigger
  9. We can get the camera OOB to cause the level to unload, and the speeder can drop through the floor. Then we can land on the falling barrel section.
  10. With enough speed, we can make it to the moving tracks on the edge of the level, and then meet up with Belina. Hit the save trigger, then save/quit.
  11. Continue DIM #2 from the explosive barrel section.

Skip to 2:50 for the cutscene skip

I could not find a way to skip directly to Galdon, maybe someone else can pull it off.

==============

Update: The dual navigation sucks, but it can be learned. The speeder (usually) acts like a compass that points towards Fox. The hard part is getting Fox to the right locations. The speeder can easily follow.

It is hard to explain the nuance, but after some practice, it is fairly easy to do the trick.

To control Fox: L-Target to lock the camera at a good angle. DO NOT PRESS A, or Fox will mount the speeder again, ruining the trick. To control speeder: Hold R to use Fox's shield, then we can press A to accelerate the speeder without mounting it again.

Edited by the author 2 years ago
San Francisco, CA, USA

Managed to get to the Galdon portal area on a bike. Can't get onto the portal itself though. Not sure if it can be interacted with.

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

Probably useless, but it is possible to ESW to the same file

  • Save on File #1
  • Keep playing without saving, and hit an ESW trigger.
  • Quit, but do not save.
  • Load File #1, and die. Save when prompted. Voila, we have ESW'd to the same file.

This can be used as a way to keep items we normally turn in (Power gems, Alpine Roots, etc).

We can (temporarily) avoid spending Fuel Cells. Unfortunately, the game will think we did not fly to the dungeon, and will make us pay later.

I tried using the Alpine Roots from the Tricky section to feed the mammoth in DIM. Didn't work, they are different items.

Edited by the author 2 years ago
josejavier1158 and BvqRzxi5 like this
San Francisco, CA, USA

It seems the Mammoth OOB is v1.0 only. I spent over 30 minutes trying on v1.1, but I could only do it with a speed hack AR code.

However, on v1.0, I could easily do the glitch.

I am not sure if they fixed the mammoth, or just moved the wall collision.

Edited by the author 2 years ago
San Francisco, CA, USA

Mammoth #1 clip is possible in v1.0 without AR codes! Unconfirmed if this works in v1.1.

==========================

I spliced a run to see how long the entire skip might take

The world record takes 12 minutes to get from mammoth #2 => Galdon

With this skip it may be possible to beat this just barely with extremely optimal play. Not worth it for how hard the glitch is.

  • 5 minutes just to get from mammoth #2 to speeder bike
  • 2? minutes of speeder/Fox navigation (5m45s in this run, but I was very slow)
  • 4.5? minutes to get to Galdon

This should save time in TAS/ESW though, since we can do it with mammoth #1.

EDIT: Also, TAS/ESW does not need rocket boost for DIM anymore! This cuts out the extra trip back to DIM.

Edited by the author 2 years ago
San Francisco, CA, USA

There are two additional ESWs in the Sun / MoonStone room.

There are videos of people using these, but it has nothing to do with collecting the Sun/Moon Stones. There is just a regular ESW checkpoint next to the stones. All WC ESW locations can be used even if the room is unloaded.

The total known ESW locations is now 23.

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

Normally when swimming, it is impossible to go downwards. However, I think if Fox never rises to the water's surface, then it is possible to get pushed downwards when colliding with ceilings.

Strangely, we do not get forced in bounds here, as somehow we are swimming above the ceiling. The loading trigger is too low, so we can't hit it using this method.

This could be an alternative way to get K4 Early if we can find a way to keep Fox's head colliding with something after entering the water by the blue mammoth. Probably can't work, as Fox would just clip up through all terrain.

Edited by the author 2 years ago
josejavier1158 likes this
San Francisco, CA, USA

I have no idea how I did this, because I can't reproduce it. I might have had to hit certain loading triggers first.

This doesn't save time unless we can find a consistent setup and a way to get down there without breaking the wooden door.

Edit: The trigger for this is in the central wind tunnel outside the Queen's room. So this likely will never save time.

Edited by the author 1 year ago
San Francisco, CA, USA

Super useless but funny

I was testing out some void out stuff using moon jump AR codes, and somehow triggered an animation test mode

For those curious, this is what I was doing right before it happened

JubJub62 and josejavier1158 like this
San Francisco, CA, USA

With all of the recent speeder discoveries here, the next obvious thing to try is an Ice Mountain skip.

The goal would be: A ) Any sort of speeder OOB (Ideally during the race., but maybe we can start the race while already on the speeder) B ) If not dismounted yet, climb back up the mountain and dismount with a Fuel Cell discovery cancel. Might need to kill the SharpClaw first to avoid losing the race. C ) Win the race while dismounted. I think if both are standing on the trigger this should work (I hope). D ) ???. Perhaps we can get Tricky, avoid the save trigger, and Save/Quit back to the top of Ice Mountain?

We can get to the speeder early with an explosive barrel clip, but the problem is that the speeder can only be interacted with while the door is closed:

=============

Also I think I was able to memory leak in Ice Mountain. I zoomed 10 times while OOB and the game soft-locked, but I couldn't do it again.

Edited by the author 2 years ago
San Francisco, CA, USA

Death warp can save 5-10s in Dragon Rock:

If my timings are right, a Save/Quit warp takes almost exactly the same amount of time as running.

The current world record run dies and uses a Bafomdad in this room! I think it would have been more optimal to dodge the fire (Fox's health was 1), and death warp out. This probably can't be used in every run, but it's worth taking advantage of if the opportunity arises.

Should be easy to take additional damage though (run into flames on ladder/path barrel, throw barrel into wooden wall at point blank, etc)

Edited by the author 2 years ago
josejavier1158 likes this
Virginia, USA

I already know about this. There is no consistent way to dodge that fire, sometimes it does happen. I have 1/4 of a heart if I haven't already used the bafomdad. It is routed so that I can sometimes go for it. There is more than 1 luck factor. Taking more damage wouldn't help the fact I'm already low on health. The reason why you always have low health is because of the much more significant death warp in Snowhorn Wastes. The optimal health is 3/4 when starting the trial for K4, and you need to have good luck on the first ladder in DR, get the fire dodge, and not take any extra damage after the SW deathwarp. Just being able to go for it is very difficult in a practical sense.

josejavier1158 and zcanann like this
Japan

We can warp from ESW point to another location.

  • Go to ESW point and quit
  • Load another file and die
  • Respawned at ESW point without saving
  • Save and reload the file

If do this, should be able to skip the move from ThornTail Hollow to Volcano Force Point 2 in any file(I haven't done it). But it doesn't make sense because it takes time to setup file.

josejavier1158 and zcanann like this
San Francisco, CA, USA

Huh what the hell, you're right.

It seems we can warp the "setup" file to the location of Fox in any other file.

I tried this with one file in DIM, the other file as Krystal, and it just corrupts the save file (loads into blackness). I think trying to do this with Krystal causes file corruption.

This can work across different maps/dungeons. And it can be used to trigger warp cutscene events (similar to trying to ESW as Krystal)

Edit: Maybe we can trigger the K4 warp pad to get inside the cage. I tried testing this, and for some reason ESW does not work in most of SnowHorn Wastes. I can only do it by the frozen lake (with the ice block)

Edit 2: So far every time I have done this trick with Krystal, it results in a corrupted file. I tested these locations:

  • DIM gate
  • CRF gate
  • Thorntail Egg event
  • Moon Stone (start of bridge)
Edited by the author 2 years ago
Game stats
Followers
210
Runs
234
Players
40
Latest news
UPDATE: Rules and Category Changes [01/23/24]

As of today, new categories and rules have been added to the leaderboard. The following has changed.

Here are the following new categories and changes added to the leaderboard:

  • Spellstone 2
  • Spellstone 1 will now be a sub-category under the new category "Spellstones" along with S
29 days ago
Latest threads
Posted 1 month ago
6 replies
Posted 6 months ago
190 replies
Posted 8 months ago
25 replies
Posted 1 year ago
2 replies