BhdTool
1 year ago
France

Hello!

It's been a while since I've posted to any Resident Evil related board :p

I have been working the past days on a personal project to teach myself some reverse engineering and REmake was my guinea pig.

So, I've ended up making a dll that hooks to the game and adds several tools through an ImGui to help with speedrun practise and other things :

  • A toggle to enable/disable Door Skip at will during runtime
  • A tool to Jump to any room in the game
  • A tool to edit the inventory
  • A tool to save anywhere

The ImGui interface can be brought up anytime ingame by pressing F5.

The tool also creates a config file upon running & closing the game once, which can be used to completely disable it. (It will then not tamper anything in the game's memory and the game can be run as if the dll was never injected).

Built binaries of the tool, its source code and more information can be found on my GitHub over at https://github.com/eleval/BhdTool

If you have any question or any request, let me know :)

Kenjamin, ISH and 4 others like this
Michigan, USA

being able to go to any room in the game would be a major help for practicing vs loading up saves. Would like to see how pessi feels about it.

Unlawful likes this
Argentina

Any way to have infinite bullets by editing inventory? Like Infinite Shotgun

Edited by the author 1 year ago
France

@BrianNazziTV I can add an option for that yes.

France

New BhdTool release (v0.3).

List of changes:

  • Fixed crash when switching the game to fullscreen. (should also fix other graphics settings related crashes)
  • Fixed Door Skip option not being applied automatically when the game is launched.

The new release can be found there : https://github.com/eleval/BhdTool/releases/tag/v0.3

I still need to fix the elevator sound not stopping when entering the lab as well as some issues with SRT. Hopefully I can get both fixed for v0.4.

EDIT: The SRT issue appears to be fixed as well as of v0.3, probably related to the same issue as the fullscreen crash.

Edited by the author 1 year ago
France

New BhdTool release (v0.4)

List of changes:

  • Fixed Lab Elevator sound looping non-stop when doorskip is enabled.

The new release can be found there : https://github.com/eleval/BhdTool/releases/tag/v0.4

Sorry for the triple post 😅

France

New BhdTool release (v0.5)

List of changes:

  • Fixed crash when alt+tabing
  • Fixed Keyboard controls no longer working when using the tool.
  • Fixed Save Anywhere tool corrupting a trigger in the room it was used in.

The new release can be found there : https://github.com/eleval/BhdTool/releases/tag/v0.5

Kenjamin and TikiLiger like this
Ireland

Hey Eleval!

Thanks for this, I just heard about it from Pessimism on his stream.

Maybe I'm missing something but it seems like F5 isn't working in game, but the config file was created.

I downloaded the zip file and put both files in the same folder as the game .exe. Am I missing something else? Should the GUI open once the game has booted to the main menu or does it need to actually be in game?

I know the json file needs me to do some other stuff for it to work but I'm not too worried about that at the moment., for now I just want to try the new doorskip.

It's 3:30am here at the moment so I'll take a proper look tomorrow. I haven't ran REmake in a while but I remember having an issue before where the framerate cap would mess up if I alt tabbed out, and I think I tried using SpecialK at some point so perhaps there's a conflict there.

I appreciate your work on this and apologies if I've missed something simple in my tired state! :D

EDIT: So with a brief test, looks like I had to use Special K to fully uncap the game otherwise MSI Afterburner shows it running at 60fps instead of 120, regardless of setting the game to run at Variable/ 120. Not using SpecialK also sometimes gives me some issues with resetting Livesplit and having Gamepad Viewer working.

So maybe there's a conflict between the dlls? I'm not educated enough to know but I think it should be ok. Your dll is dinput, and Kaldaien's is d3d9 so I don't think there should be an issue there?

Apologies for the long post but hope that info helps!

EDIT 2: So I disabled SpecialK, fixed the fps cap, and also got Gamepad Viewer to keep recognising inputs once the focus is on the game window by changing to a different controller from DualShock4. Still can't get your GUI to open in game with F5. I enabled doorskip in your config file and it seems to be working fine.

Edited by the author 1 year ago
Brazil

I had the same issue as you, but when I launched the game in windowed mode the GUI opened by pressing F5, so I think this is how it works.

You must play the game in window mode to properly launch the tool.

Ireland

Hey GamesRock, sorry for the delay.

I tend to not run games in windowed mode so I probably never thought to try that. I'll give it a go later and see how things go. Thanks!

United States

Am I missing something? Is there some other program I'm supposed to have? I dropped the the .dll and JOSN files into the game folder (Steam\steamapps\common\Resident Evil Biohazard HD REMASTER) and my game won't open at all. Opens just fine if I remove them.

I've been using Stainless' Automatic Door Skip Mod, but I heard this one was faster, however I can't even launch the game now.

Edit: Oh I guess it's just current broken. Found my way to the speedrun server and saw some saying it isn't working since the update.

Edited by the author 10 months ago
France

New BhdTool release ! (v1.3)

I have fixed the tool no longer working since Capcom updated the game earlier this month.

I have also taken this opportunity to fix a few things and add a couple more features.

You can download the tool's latest version as well as find the full changelist here : https://github.com/eleval/BhdTool/releases/tag/v1.3

Let me know if any issue arises :) (Open an Issue on GitHub if you can, easier for me to see as I don't frequently check the SRC forums).

Edited by the author 9 months ago
AlbertFnWesker, Waterslidez and 3 others like this
Connecticut, USA

I have put the BHD Tool in the RE1 folder but f5 isn't doing anything.

France

Hi Bigaloe, you probably missed something because I did it recently and it works :) try to reset the process

Gelderland, Netherlands

Tried to install the tool, put the files in my game folder but to no prevail. The Tool does create a .ini file which i had to adjust to get Doorskip to work but, the rest of the Tool is not working for me as well. Pressing F5 does nothing and i know others have the same issue. Help would be very much appreciated <3

Edit: Figured out why the Trainer wasn't working. It doesn't seem to work in Fullscreen. If you still want to run in full screen with the trainer, get Borderless Gaming app and it should work.

Edited by the author 2 months ago