Forums  /  Meat Boy series  /  Super Meat Boy  /  Dr.Foetus bug
  DanonymousDanonymous

EDIT : FIXED
I want to speedrun that game but I have an annoying bug.
I am unable to beat the last boss because he is so quick that i cannot reach the end of the level before him. (even with v-sync enabled)
I have find the origin of this‚ it is because my laptop has a 120Hz monitor.
The only way to solve the problem is to limit the game framerate to 60fps but the game become extremely slow.

Here is exactly how my problem lools like :

Does anyone has another solution to my problem?

BoogieBunnyBoogieBunny likes this. 
  MisteurMisteur

The 120Hz monitor is definitely the problem, if limiting to 60 fps works that's the solution 😛

All runs here (with the exception of all glitches) are ran in 60fps, almost sure it's in the rules, so yeah again if limiting to 60fps works there's no problem here :>

gl on the runs 🙂

 
  DanonymousDanonymous

I feel that when I limit my fps to 60 the games looks slower than it should.
My game looks like that :

When i am recording i don't have these strange glitchs and i am able to finish the last level.

 
  StarlitSentryStarlitSentry

That's definitely slow. Can you check what fps you're getting in game with some software? Also try enabling vsync at gpu control panel level.

 
  DanonymousDanonymous

I get 60fps (i have limit it to this value) and i have enabled vsync

 
  MatteMatte

Some monitors have an option to lower the frame rate. Do you have that option?

 
  DanonymousDanonymous

nop i play on a laptop so it is impossible to lower the refresh rate unfortunatelly

 
  MisteurMisteur

Oh yeah my bad that's really weird, doesn't look like 60fps at all, this might be a bit random but if vsync is what causes the problem it might be worth try to disable it and limit the game's fps with Rivatuner maybe ? It's a program we use to stabilize the game at 60fps, might be worth a shot I'd say.

You can find it on that page : https://www.speedrun.com/smb/resources

 
  DanonymousDanonymous

I have try to use it but i couldn't install it because apparently it doesn't work on my version of windows 10 (the latest update)
even if i use the version from msi afterburner

 
  MatteMatte

There is always the option of getting another monitor. It is not ideal but it is an option.

 
  DanonymousDanonymous

For now i think i will speedrun the game and just not do the last boss level.
That's not a huge issue i just wanted to know what time i can get and not fight for WR.

 
  StarlitSentryStarlitSentry

While I can certainly see why that's preferable to monitor replacement, (I wouldn't suggest this one for the sake of a game unless you knew you wanted to throw A LOT of time into it), the chances are it is effecting other places in the game too. Saw cycles, lift speed, other boss animations and even character mechanics for other characters.so figuring something out would be for the best.

It's a bit odd that rivatuner doesn't work but there almost certainly has to be an alternative.I'm on the latest version of Windows 10 too so it shouldn't be that anyway.

Mind me asking if you've tried both windowed mode and full screen btw? Silly thing but this game is janky enough that could honestly make a difference.

If you get msi afterburner you should be able to get an on screen display for both framerate and refresh rate just to be sure both are correctly locking. It's very strange if both are, your pc isn't overloaded which it really shouldn't be almost regardless of specs unless you have a lot on in the background or wayyyyy too high settings on recording.

MisteurMisteur likes this. 
  DanonymousDanonymous

So now rivaturner works perfectly well and when I don't limit my framerate with vsync enabled i get 120fps constant and it seems that the whole game is running at the normal speed ( obstacles' speed...) but bosses (dr fetus and brownie) are too fast (I cannot go faster than them). I have compared theses obstacles speeds with other videos of speedrunners with a timer and it was exactly the same.

But while limiting my framerate to 60fps all animations, obstacles speed , menu speed are really slow but boss' speeds are normal. Enable vsync or not and windowed or full screen doesn't change anything.
All of that is really weird 😕

And where in msi afterburner can I activate refresh rate display I don't find it? I have only find related to frames : Framerate and frame time (don't really know if I should care about this vallue).

 
  DanonymousDanonymous

What do speedrunners usually do when they have a monitor which have more than 60Hz refresh rate?

 
  MatteMatte

You could try the beta version if you are running meatboy in steam
->right click Super Meat Boy in your library,
->Properties,
->Betas tab,
->type smw1234567890 as the access code,
->select smwbeta from the dropdown menu.

 
  DanonymousDanonymous

Thanks a lot it works perfectly while limiting the fps to 60.
The only small issue is that the livesplit autosplitter doesn't work anymore.is there a way to make it work? It was practical but not essential.

Now I can really start to speedrun that game.
Another time thank you.

AlcoweAlcowe and MisteurMisteur like this. 
  kingshroomskingshrooms

you can try running livesplit in administrator mode