Resident Evil 2 Forum  /  FMV problems

Hi everyone, new speedrunner here!

I installed the sourcenext version of RE2 yesterday, but i have a problem with FMVs, after a fresh install, in the first run of the game, the FMVs play perfectly. But if i close the game and get back to it later, i only get a black screen and sound, but no FMVs, not even the Sourcenext pre-title video, not the CAPCOM video, nothing, and some of the music is missing in the run.

I tried installing the K-Lite Codec Mega pack, but it didn't fix anything. I heard in the discord that there are some replacements FMVs that don't use the old codecs, are they ok for speedrunning? if they are, where can i find them?

My rig:

W10 professional 64bits
i5-2550k @33.4ghz
8gb ram ddr3
GTX 960 4GB

PS: i tried changing compatibility settings, tried every single one of them, but they don't solve anything, and i don't know if the credits will play if i have this bug, i don't want my runs to be rejected for it 🙁


Afaik there is no problem if you don't get the FMVs played. I got that issue also and a runner told me that even you can deactivate them with Windows Registry for the runs and still valid, so since you skip them idt you'll have problems if FMVs are not played


funny you should say that my sourcenext re2 is doing the same thing, FMV's wouldnt play but you could hear them. Just randomly started doing it like a week ago roughly. A win10 update must have broken stuff 🙂 #standard


This problem with FMV's isn't just a win10 problem, this has been a thing even on windows XP, 7, vista etc. It's not a big deal for a speedrun, most people turn them off completely in regedit anyway.