Forums  /  Zelda series  /  The Legend of Zelda: Link's Awakening DX  /  I have a problem
  ArjayArjay

Hey guys,

I've been following tutorials on how to speedrun LA,
everything goes great until I have to go to D2

The tutorials show that you have to get the powders from the shop but when I try that, the powder isn't there.
I tried on both English as Japanese games but both were a no go.

Can anyone help me or direct me in were i maby wrong?

Arne

 
  ArjayArjay

I've just checked and if I go to the shop in the beginning of the game then the powder is there (but I have no money yet).
If I go after I get D1 key, the powder is gone.

 
  BambooShadowBambooShadow

don't get confused with the routes!
1.) "old" route:
- don't pick up the mushroom in the forest
- get the powder from the trendy game

2.) "new" route:
- pick up mushroom in the forest
- turn it in at the witch's hut on your way to D2

==>once you picked up the mushrom, you can't get/pick up powder anywhere else in the game -->you first have to turn in the mushroom at the witch's hut!!!

that should solve your problem

 
  ArjayArjay

OOOOOOH! ok thanks soo much for this 😉 jup that solved it!

 
  ArjayArjay

another problem I have is that my link's awakening rom doesn't work on my Gambatte emulator.
i keep getting a message that it needs a GBC bios.

 
  spicefatherspicefather

Check the 'Emulator Resources' link in the resources section here. It has downloads and instructions for getting everything set up.

 
  ArjayArjay

Thx that helped!

I have another issue.

Sometimes when I use the mushroom to move over a pit or when I use it to get the boss Key in til cave it freezes my emulator. Ive tried the BGB and the gba emulator and it does it on both.

 
  spicefatherspicefather

That can happen if you open S+Q menu before you finish moving on the pit. You can make it safe by buffering S+Q out of the text box afterwards, or just practice the timing.

Or you can just do the no-shroom route. I'd honestly just recommend that since it's not worth losing runs to this kind of stuff when you're starting out.

BambooShadowBambooShadow likes this.