Problems installing the patch
1 year ago

I'm new and I don't understand the installation of patch 1.2 a little. I get an error

Verifying current "Dishonored2.exe" version... invalid file. Wrong game version or corrupted file. md5: f2b661205568473ae907524072891fc9

The installation cannot continue. Aborting.

Who had it, how did you decide? Thank you in advance!

Game stats
Followers
797
Runs
927
Players
271
Latest threads
Posted 3 years ago
13 replies
Posted 4 months ago
1 reply
Posted 1 year ago
0 replies
Posted 2 years ago
4 replies