SkyRoads Forum  /  Cycles issues?
  TenkaTenka
(edited: )

Hey guys I made a few IL submissions just recently and am a little concerned.

The rules didn't specify any Cycles requirements so I set DosBox to max cycles for my run. The game seemed to run reasonably fine, it felt as fast as I remembered back when I used to play it on a 486.

I managed to complete all IL's up to Misty, however doing my Red Heat and Into the Sun runs ... I got them flawless, just as @OuaisMaisNan did, but I somehow gained a rather large amount of time in comparison to his runs (around 7 seconds or so). Way more than I would have expected since there were no mistakes in either run.

After going back and watching @OuaisMaisNan 's runs I noticed his seemed to lag a little bit in places, which may explain it. It feels unfair to gain such large amount of time due to a Cycles advantage, but on the other hand .. I don't think this game should run with any lag.

I'm not sure how you wish to proceed with verification, please let me know if this is an issue. If you think it is unfair then feel free to reject, but if that is the case please specify the correct DosBox cycles to run at in the rules.

As far as I can tell though, max cycles looks like it reasonably represents real hardware..

607607, yanounaiyanounai and IglumIglum like this. 
  yanounaiyanounai

Hi sorry i'm a bit late, i've not seen this post... My runs in IL is nearly the same of yours i guess. Maybe my DOSbox is lagging but i don't think that's it, cuz my PC is ok. So this is probably the cycles number : My cycles number is set to 3000 but i don't know how to set it to max... that's probably the problem

I've tried ctrl + F12 but don't works (maybe cuz i'm on mac)

607607, TenkaTenka and IglumIglum like this. 
  IglumIglum

There is a config file for Dosbox that is a text file. You can open it with a text editor and change cycles=max .
https://www.dosbox.com/wiki/Dosbox.conf#cputype_.3D_auto_.7C_386_.7C_386_slow_.7C_486_slow_.7C_pentium_slow_.7C_386_prefetch

Join this Discord if you need help.
https://discord.gg/eM5ksWn <-- MS-DOS Speedruns discord

607607, yanounaiyanounai and TenkaTenka like this. 
  TenkaTenka

@ouaismaisnan hey dude. Yea by default with Cycles is set to Auto, DosBox will identify SkyRoads as 3000 cycles which is incorrectly low. (It does this with a lot of games).

Depending on how you are running DosBox you can either edit the Dosbox.conf file as @Iglum suggested, or if you are working directly from the Dos prompt within DosBox you can type in: "cycles max" before running the game.

PS: We have started an MS-DOS speedruns Discord where you can reach us and chat live if you need any further help: https://discord.gg/bmPm4Cg

607607 and yanounaiyanounai like this. 
  yanounaiyanounai

Ok cool 😃 But i just don't find my DOSbox configuration file i tried things wrote on the dosbox wiki but still don't find..

 
  TenkaTenka

According to the dosbox wiki:

"Mac OS X
If you are using Mac OS X, a preferences file will be created for you on the first time you run DOSBox (as of version 0.73). This file contains the same system settings and initialization values as the dosbox.conf file on other systems.

It can be found (and modified) at ~/Library/Preferences/DOSBox 0.73 Preferences, where ~/ is your user profile folder (usually /Macintosh HD/Users/username/). The exact folder name in the Finder may vary, depending on the language you use for OS X."

Try that folder. If you find that file then inside, look for the line "cycles=auto" and change to "cycles=max"

 
  TenkaTenka

How are you using dosbox? Are you running skyroads from shortcut? Or are you loading dosbox first then mount drive folder and run game from dos prompt?

 
  yanounaiyanounai

i've already tried your quotation of dosbox wiki and it still don't works... quite strange.
I launch DOSbox and mount the skyroads file like indicated in the help mount.

 
  yanounaiyanounai

I've redownload DOSbox and just replaced 0.73 Preferences by 0.74 Preferences and that work now x)

TenkaTenka likes this. 
  TenkaTenka
(edited: )

"i've already tried your quotation of dosbox wiki and it still don't works... quite strange.
I launch DOSbox and mount the skyroads file like indicated in the help mount."

Ok .. so I assume you go through this process:

mount c <skyroads folder>
c:
skyroads

Is this correct? This is how we mount and run games on PC. If it is corect, then what you need to do is: before the "skyroads" part to run the game. Type in: "cycles max". So all up it should look like:

mount c <skyroads folder>
c:
cycles max
skyroads

 
  TenkaTenka
(edited: )

Ohhh .. I understand what you mean now. Yea because you have 0.74 .. need to change it from 0.73 to 0.74 .. hahaha.

yanounaiyanounai likes this. 
  wuchtawuchta

I remember playing this game as a kid, damn.

TenkaTenka and IglumIglum like this. 
  TenkaTenka

Its still a great game! 😃

Pretty hard though haha.

 
  TenkaTenka
(edited: )

@Qanik

Ok, I have received your new run. Unfortunately you seem to be losing time in the loading screens.. which points again .. to a cycles issue.

Here is a comparison video I put together of yours, mine and @Mr_R 's red heat run.

To answer your question though .. the route DOES matter, as you can gain or lose time by exploiting the "jump-o-master" (where it says IDLE down the bottom right). On certain jumps you can force it to pull you ahead, and it will change from IDLE to IN USE. This is what I have done a lot in my Red Heat run which has made it slightly faster.

You can see in the comparison how my run pulls "slightly ahead" of @Mr_R 's .. which is about what I would expect if everything is set correctly.

However, in your run you still are losing way too much time to loading screens ( the part where it fades to black). The correct timing for your run is actually 1:04.206 (you forgot to count the fade in from selecting the level at the start) ... are you absolutely sure you set the cycles to max?

Edit: On closer inspection I do see some amount of lag as well in your run .. particularly on Road 3. You can see the frames skip as you jump/move right and left. Your run does appear to be smoother than your original.. but far from what it should be. ..

What other options are set in your DosBox config file? .. can you please post the entire cycles section? I will compare it with what I have and see if anything is different.

 
  TenkaTenka

I will verify your current run as 1:04.206 .. though I really hope we can figure this out. I wonder if its because you are on a Mac ?

 
  yanounaiyanounai

i have :
core=auto
cputype=auto
cycles=max
cycleup=10
cycledown=20

but if this is still don't work i can switch my computer to windows

 
  yanounaiyanounai

I don't know if my cycles configs are ok...

 
  TenkaTenka
(edited: )

That .. should be ok...

On PC if you run in windowed mode it tells you the cycles at the top of the window bar:

https://i.imgur.com/LH3SsM6.png

Do you have a way to do this on Mac ? .. this would help confirm.

 
  yanounaiyanounai

yes i've the same things marked in the top
if this is still lagging i can go on windows

 
  TenkaTenka
(edited: )

yea ... try it on windows and see how you go.

One other possibility is you have a different version of the game (I wasnt aware of any different versions .. but its always a possibility). Can you join the discord server we posted earlier? - https://discord.gg/bmPm4Cg

It might be easier if we do this in real time instead of over forums.

 
Latest News
View all
No news
Recent Threads
View all
Thread Author
Autosplitter?
Last post
StrandedKnightStrandedKnight
4 replies
Cycles issues?
Last post
TenkaTenka
21 replies
Thanks for Moderatorship
Last post
TenkaTenka
3 replies
Level Leaderboard ?
Last post
yanounaiyanounai
2 replies