Forums  /  Grand Theft Auto: The Ballad of Gay Tony  /  Load time removal
  Super Modpossessedwarrior

This is an update to the autosplitter script to include load time removal. Give it a shot.

state("EFLC")
{
uint missions : "eflc.exe",0x00DA58B0,0x10;
uint isLoading : "eflc.exe",0x00099F90,0x10;
}
start
{
}
split
{
return current.missions == old.missions+1;
}
isLoading
{
print(current.isLoading.ToString());
return current.isLoading==0;
}

Rave, Lanayru and Noz like this. 
  Noz

Did the first couple of missions and seems to work, stopped timer counting all the loads, fades in and out for cutscenes, taxis also stopped the timer for the fucking awful inconsistent I Luv LC load we time in RTA SeemsGood

 
  Mawfeen

Any chance of modifying it for IV? @anyone

sick stuff

 
  storm849

what version does this work for? I can't get it to work either on 1.1.2.0 or steam version

 
  Rave

Updated autosplitter + load time removal for support with both 1.1.3.0 and 1.1.2.0
https://gist.github.com/jfoster/37f266491e3caacc807d8be9d144e38b

Super ModJolzi and storm849 like this. 
  storm849

5 months late 🙁
Thanks though!

 
  Rave

Just pushed an update to the script to fix a glaring issue in which using the video editor causes the timer to reset. ?

@storm849
Better late than never! I recently took interest in this game and I'm wanting to learn and run it. However, naturally I'm too lazy to split manually, so this script needed updating. ?

 
  storm849

This was my first full speedrun and it was pretty fun. I think you'll definitely enjoy it.

And yeah manual splitting sucks, so I just ran a timer without splits. 🙂

Again thanks for updating it. I was gonna do it myself 6 months ago but was too lazy to learn how to do it 😕

 
  SolusOHKO

The autosplitter doesn't work for me. I tried downgrading as well and it recognizes both versions, but doesn't start or split.

Update: If I change the false to true the script clearly works, but I can't figure out what is wrong with it.

 
  Roxxers

I moved to this autosplitter and it worked for me. My version is Patch 2 using the xliveless crack. I think the crack also needs to be on for it to work. https://gist.github.com/jfoster/37f266491e3caacc807d8be9d144e38b It has cases for both Patch 2 and Patch 3. The start and resets are funky and it doesnt split at the end. But it does everything else. Just the beginning and ending need to be done manually. Though I think it would be hard to automate those as it is. Make sure to disable start and reset in livesplit when adding the script.

SolusOHKO likes this. 
  SolusOHKO

Yeah, it turned out I needed xliveless for it to work. Should be available in the resources here and specified you need it to work and maybe a guide or something on how to install it. Had to look up a youtube video to figure that out even as the readme doesn't specify the location or anything.

Thanks for the response anyways. I wouldn't have ever gotten it to work otherwise.