FaghettiFaghetti

Hello, Brandon it is I, Crafti_Snake, who was on your stream to ask about this game a little while back 🙂

Here are some of my technical questions:

1) How should I go about speedrunning it?
2) Do you know a place I can download it since my laptop do not have a cd-port?
3) How do you usally set up the splits, recording etc.?
4) If I wanna stream it for fun's sake, how can I do that?😮

Some extra subjective questions:

1) Is it a hard game to get into?
2) What is the worst thing about speedrunning this game, and would you say it is a good game to speedrun?
3) Is there a lot of room for improvements? (a.k.a not Mario level hard wr chasing with frame perfect inputs every second)
4) What is the best thing about this game speedrunning wise in your opinion? 🙂

I got WSplit, OBS studio and XSplit Gamecaster 🙂

CapridogCapridog, MasterLeoBlueMasterLeoBlue and XYXXYX like this. 
  XYXXYX

1) speedrun it at your own pace, perhaps learn the easy stuff first for awhile then move onto harder strats.

2. check the resources for various downloads.

3. you can locally record with OBS or record with twitch functionality.

4. just stream it, its fun just playing it live!

1. its a easy game to get into but very demanding for good pbs

2. worst thing is the dropped imputs imo

3. all wr's can be improved SIGNIFICANTLY.

4. best thing is the game itself

FaghettiFaghetti likes this. 
  FaghettiFaghetti

I tried the download links, but it keeps saying "Toy Story 2 is not correctly installed, please re-install" - can you give a guide on how to download?

XYXXYX likes this. 
  XYXXYX

to bypass that error run the game as admin

 
  cheeseandcerealcheeseandcereal

You can follow my video which helps to get rid of a lot of the common issues most PCs have running this game nowadays.

 
  FaghettiFaghetti

Thank you :3
I watched your video, but my program doesn't even go past the "Starting up... please wait" bit.. I waited for hours and nothing happened.

 
  cheeseandcerealcheeseandcereal

Did you run as an administrator? Also when you say "my program" are you referring to the installer or the game?

 
  FaghettiFaghetti

The game, and yes I tried both with and without administrator. :C

 
  FaghettiFaghetti

Can it be that it does not work with Windows 10?

 
  hdc0hdc0

cheeseandcereal's video shows how to run the game on Windows 10.

At which time in the video do you get the error? You said that your game hangs at "Starting up... please wait". I never got this message so I don't know at which step your game fails to load.

 
  FaghettiFaghetti

The very beginning. I download the game installer - click on install as administrator - then it opens up this black screen with "Starting setup... (Please be patient)". And then it just never moves on to the actual game install screen as it does in the video.

 
  hdc0hdc0

So the installer fails, not the game. Try to install it manually:
Copy ToyStory 2 PC Installer.zip\Setup\Toy2\HD to a directory you have write access to (e.g. C:\Users\<Username>) and rename the HD directory to ToyStory2.
Then start a command prompt as administrator and run these commands (replace C:\\Users\\<Username>\\ToyStory2 with your game path first): http://pastebin.com/kYEZ5TTE

 
  cheeseandcerealcheeseandcereal

You can also try extracting ToyStory 2 PC Installer.zip, then navigating to <extracted directory>\Setup\ and run SETUP.exe as an administrator, then do the remaining bits like configuring dgVooDoo manually. Or try the more manual option mentioned above by hdc0. I was confused because you said the game wasn't starting, but you were referring to the installer, not the game.

 
  FaghettiFaghetti

Sorry guys, I'm not so good at that kind of stuff and despite my efforts, I just can't get it to work. Guess I have to find something else to speedrun. 😕

 
  cheeseandcerealcheeseandcereal

Just to confirm, you extracted the download before running install.exe, correct?

I suspect that you may not have extracted the download, but rather just ran the installer from within the zip file. If you did this, the setup won't do anything, since it won't have all the files it needs to run.

If you click on the downloaded file, you should get a screen like this: http://i.imgur.com/KTtLQ73.png

Click on that Extract all button, then click on "Extract" from the window that pops up. After it's finished, it will open a new folder that looks like this: http://i.imgur.com/bDNv8N4.png

Note that it doesn't have the extraction options in the bar up top, because it's a folder, not a .zip file (Also the address bar DOESN'T say Toy Story 2 PC Installer.zip).

Once you have extracted the download and it looks like the second screenshot, try the installation process again.

 
  FaghettiFaghetti

Okay, I'll give it another shot 🙂

EDIT:

Like before - this is how it looks:

http://imgur.com/iEelp9U

Run Installer as administrator still gives me the same boring result:

http://imgur.com/kAuZU9V