Forums  /  Phantasy Star III: Generations of Doom  /  Different Versions + Inventory Underflow list
  Jiseed

Hi guys, I figure it'd be nice to catalogue what happens when you attempt the inventory underflow (empty the inventory and use an item in battle) in the various versions of the game that have been released. Obviously the GBA version doesn't crash, but perhaps there are others as well. I'll start with the ones I've done:

Genesis EN/JP: Crash to title
Steam EN: Crash to title
GBA (Phantasy Star Collection) EN: Inventory underflow
Saturn (Sega Ages 1998: Phantasy Star Collection) JP: Hardlock
PSP Sega Classics Collection EN: Crash to title (odd stall compared to other consoles, but might be an emulation error)
Wii VC EN: Hardlock

I'll keep testing as I get my hands on other versions. Hopefully we can get some contributions and I'll update the list periodically.

 
  MrStarbird

The Wii VC version freezes the entire console iirc when I tested it.

That still leaves the PS2/3/4/PSP, Xbox360/One, and Switch versions to test out (though theoretically, the PS3/X360 should run the same as should the Switch/PS4/XBOne).

The reason the GBA version doesn't crash is because I believe the ROM itself is different (to accommodate the size of the GBA), since that version is not a straight port unlike the others. While almost every other version is a straight port ROM that plays right to a built-in emulator, the GBA version was rebuilt along with the other two games (which is why using the duplication glitch in PS2 locks the game as well and which is why the damage calculation/evasion rate in PS1 is much higher).

Still will be interesting to see what happens and if there is another version out there that would create an inventory underflow. I feel like there's something we're missing with this game that could break it open for the non-GBA versions. I mean, have we tried this out with every possible item that can be used in battle? Would an offensive item like the Force Sword (I think that casts Foi) do the same thing as a Monomate? (then again, Force Sword is reusable so it might not create the effect we are looking for).

 
  Jiseed

Added PSP Sega Genesis Collection and Wii VC to the list. Makes sense that thats why it works on GBA, but might as well test it all just for posterity. I've tried a ton of items, but maybe theres a golden goose that stops it that I've missed. Worth checking out the inventory of characters who start with less than 4 items as well, the final slot could have something worthwhile. Reusable items behave normally, the spells are cast and thats that - I've tried having two people use the same item but that doesn't work either. Just have to keep at it and think outside the box, and hopefully we can stop using the GBA version lol.

 
  MrStarbird

I wonder what would happen if an inventory were emptied to 0, the game was saved, hard reset, and the glitch tried on fresh a fresh ram load.

 
  MrStarbird

Fresh ram does nothing.

Okay, so I might either be onto something or barking up the wrong tree.

I looked at the JP Megadrive version, which does carry the glitch (it also seems to be the version that the GBA port is based off as the person to Ilan to talk to in order to trigger Mieu is the same person that is required in the GBA version), but the first time I tried it (close to Mieu's lake), it locked hard-locked the game. But when I tried it close to Yaata, the game reset.

I am wondering now if this is similar to how the glitches in PS4 work where they may only trigger correctly at certain map coordinates or on certain encounters. Considering I got two different results from two different spots (and enemy groups), perhaps there is a "Magic" monster group that can give us the results we want?

 
  Jiseed

I've looked into the JP version a bit, and I'm getting the same results - sometimes a freeze, sometimes a reset. I'll keep at it and revisit the Saturn version as well. One thing I found was really interesting in my testing is when I tried using the game genie codes (no encounters, walk through walls) I had for the English version it instead called up Sean's ending when an encounter was supposed to be initiated. I wonder if this means that there might a bit of a switch up in the programming between the two versions.