Forums  /  The Site  /  Site Bugs
  mariofan366mariofan366

So there is some bug with the sorting algorithm. If you view all games by total players like here https:/​/​www.​speedrun.​com/​games#platform=&orderby=mostplayers&unofficial=off you will see Super Mario Odyssey has 2800 players and Ocarina of Time has 950 total players. However under the game's pages, Super Mario Odyssey has 1800 total players here https:/​/​www.​speedrun.​com/​smo/​gamestats and Ocarina of Time has 1500 total players here https:/​/​www.​speedrun.​com/​oot/​gamestats

 
  HabrenoHabreno

Different places using different methods to count. Not a bug, just inconsistent.

 
  TaruDuckTaruDuck

(Posted this in feedback by mistake)

Not sure if this has been reported but there is a small bug with guides. When you click on a guide, it shows the name twice in the title bar

https://i.imgur.com/q1PSpFN.png

 
  mariofan366mariofan366

@HabrenoHabreno I have been following the most spedrun games by various measures for over a year. On May 2, 2019, SR.com said that SMO had 1622 players and OoT had 1450. On September 1, 2019, SR.com said that SMO had 1753 players and OoT had 1486. These numbers matched the numbers on the statistics page under the game. Thus in 4 months SMO had gained 131 players and OoT had gained 36. Today SR.com says SMO has 2807 players and OoT has 953. That means that in 3 months SMO had to have gained 1054 players and OoT had to have LOST 533 players. As someone with a strong following in SMO I can tell you there's no way it could've hit numbers like those this fall. And there's been no massive ban or any reason OoT would have lost anywhere close to that many players. However if we go to the stats page under the games we see SMO has 1808 players and OoT has 1513 players. This would mean in the past 3 months SMO gained 55 players and OoT gained 27 players. These are much more reasonable numbers.

If the numbers aren't "glitched" and are in counting players differently, how do they count it? Because I can't think of a single way to measure it so SMO has only 23 less players than SM64 and OoT has less players than Getting Over It With Bennett Foddy.

 
  HabrenoHabreno

Algorithims, and I don't know them offhand.

 
  xDrHellxxDrHellx

Not sure if this has been mentionned before, but with the new markdown system there are some issues if you add images in category rules :

https://i.gyazo.com/a32d811cd4fe6b5ebef1eb80e57fa2d5.png

As you can see, the image goes outside of the box.

Also, another thing i've noticed : so you have the lists, you can see the little circles (or whatever they are) next to each element of the lists ;
If you haven't edited rules in a while, the circles won't show and you'll get a " - " instead.
However, if you go to the settings, edit and save, the " - " changes to circles.

EDIT : It seems like the images going outside of the box comes from lists, because for each list element it adds some padding to the right. Images aren't resized as well, so if they're too big, it gets even worse.

 
  DaravaeDaravae

@xDrHellxxDrHellx It's on the bug list. It also happens in the Audit Log with text.

xDrHellxxDrHellx likes this. 
  JokerFactorJokerFactor

I don’t know if this is known or not, so I’m sorry if it’s been noticed. The “moderators” tab doesn’t appear on “Edit Series” pages.

 
  gui.jpeggui.jpeg

I think this is the right place to post this, but I'm not sure. I don't know if this is only happening to me, but when I try to go to my profile page (gui.jpeg) it gives out an 404 error. It's happening both on my computer (even when in incognito mode) and in my phone browser. It started happening when I changed my username, I believe.

 
  Ihavenoname248Ihavenoname248

Going to second the problem with the recent date field change. I think that it's probably reasonable to require a date for current/future submissions (though I think that mods should still be able to add dateless runs), but not showing any run without a date on the leaderboards, when there are many legacy runs without dates for many games, is a pretty major bug.

As for how this would interact with leaderboard snapshots (show runs at or before X date) a run with an unknown date could just be assumed to be too recent. I suspect the bug is from treating Date: Current as "show all runs at or before today's date" when it should just show all runs.

BmanRulesYou21BmanRulesYou21 likes this. 
  thisishowmymindworksthisishowmymindworks

@gui.jpeg The reason you get a 404 is that because of your username the URL for your profile makes the server think you are requesting an image with the filename "gui.jpeg" (which obviously doesn't exist on the server). If you want to actually open your profile you can put a backslash after the URL (like so: https:/​/​www.​speedrun.​com/​user/​gui.​jpeg/​ ).

gui.jpeggui.jpeg, HabrenoHabreno and LonneLonne like this. 
  gui.jpeggui.jpeg

@thisishowmymindworksthisishowmymindworks Thanks for the help! I didn't even notice the missing backslash. Do you reckon it's possible to make it so every profile page (or every page in the site) defaults to having a backslash in the end of the URL to avoid situations like this? I know Reddit does this with all posts, so I wonder if it is possible on this site as well.

 
  EroEro

I believe the global notification setting for "Your WR has been beaten" does not get activated if the WR is an IL. I have been beaten in multiple ILs over the past days and have not received a notification.

 
  ANGEL_UNDEADANGEL_UNDEAD

Hello. I'm not sure if that already known bug or not, leaderboards for Mighty Final Fight (NES) are broken.
By browsing directly https:/​/​www.​speedrun.​com/​mightyfinalfight/​full_game you won't see current World Records by Sean 'MURPHAGATOR!' Murphy.
But at your profile, any place takes his runs into account.
Also LiveSplit and some other tools show that these runs do exist. That's confusing.
As I remember there were links to speeddemosarchive page, not to direct videos, maybe that's what causing it.

 
  LonneLonne

@ANGEL_UNDEADANGEL_UNDEAD The run is most likely missing a date, runs with no dates disappearing is a known issue

 
  NeGAtiv4kNeGAtiv4k

@LonneLonne Best time as Cody: 0:15:07 by Sean 'MURPHAGATOR!' Murphy on 2013-07-02.
Best time as Guy: 0:14:52 by Sean 'MURPHAGATOR!' Murphy on 2013-10-24.
Best time as Haggar: 0:14:24 by Sean 'MURPHAGATOR!' Murphy on 2014-01-24. its info from Speeddemosarchive

 
  KinglyValenceKinglyValence

Site question about linking videos in the rules tab of a game I moderate. In one IL rules https:/​/​www.​speedrun.​com/​spore/​full_game#Cell_Stage the YouTube video is integrated. However in this IL rules https:/​/​www.​speedrun.​com/​spore/​full_game#Creature_Stage the video stays as a link not integrated. I have not done anything different to the videos on YouTube side. I am wondering why some videos are integrated and some not and can I control which ones that are? Thanks!

 
  apple1417apple1417

Similarly to KinglyValence's issue, some bits of the rules for The Talos Principle aren't getting markdown applied.

https://cdn.discordapp.com/attachments/343897241766854656/660247022942683186/unknown.png
https:/​/​www.​speedrun.​com/​talos_principle/​full_game#Any

There are two sets of subcategory rules in that example, in case it matters, "- Complete the game through the Messenger Ending." is from one and all the 60fps talk is from the other.

 
  ElimsElims

i cannot follow a game