Forums  /  The Site  /  Site Bugs
  RiekeltRiekelt

They switched over to Markdown!

http://rieke.lt/i/n7x0v.png
makes Big text now

 
  uematsufreakuematsufreak

That's all well and good, and I've actually tried this as well, but my carriage returns (line breaks) don't work at all anymore, so instead of "Goal:" being in bold and on the next line the actual goal, I get "Goal: [insert goal here]" with the first word in bold. If I put in a second carriage return, I get a new paragraph instead. There seems to be absolutely no way to make something just be on the line directly after something else other than letting it naturally wrap anymore.

EDIT: Also, trying to use a "#" to make a header will put a blank line before the text afterwards just the same.

 
  TiltustratelTiltustratel

Notification, messages, and pending action buttons are all invisible, and the buttons to create guides, modify game categories or edit/delete runs are completely missing (possibly others, I can't remember what buttons used to be in each place). I'm running the latest chrome, but the issue persists on Edge, a completely fresh install of Firefox, and with a separate computer, all have the same problem. Tested without any addons to ensure that no conflicts were at play.

ImaproshamanImaproshaman likes this. 
  ShikenNuggetsShikenNuggets

^ this is a very weird one, because it seems some people are seeing it everywhere and on everything, whereas most are not seeing it at all, anywhere.

ImaproshamanImaproshaman and TaruDuckTaruDuck like this. 
  TiltustratelTiltustratel

I'm no web developer, so this may not be useful at all, but on checking Chrome's developer options, I see this error: https://i.imgur.com/PpPBVCU.png

Font-Awesome seems to also be tied to the triple-dot dropdowns, which a lot of the missing options are found under (such as the edit/delete run buttons). I checked in the inspect edit menu and the buttons are there, they just aren't being rendered.

Maybe that error can help figure out the cause?

 
  TiltustratelTiltustratel

Can confirm after some tinkering that this is definitely the issue, if I go into the inspect element css and manually add 'display: inline-block', to the triple dot icon (in this case element "<i class="fas fa-ellipsis-v"></i>"), I can then click the area where the dots would be and the dropdown will show.

Seems that since the fontawesome resource/css is not loading, all icons get a size of 0x0, so they are invisible and cannot be clicked, but still exist.

ImaproshamanImaproshaman and ShikenNuggetsShikenNuggets like this. 
  daniloroxettedaniloroxette

Hi.

I couldn't find a search box to look if my point was already told somewhere here. I tried google search with "inurl:" and I only reached to a closed thread 5 years ago.

Some pages like speedrun.com/streams and game series shows current livestreams and it's a nice feature. But there is a button to filter and show only games that I follow. I looked everywhere how to follow games and couldn't find it. I notice that there is a page in my settings reporting that I don't follow any game. Seems to me that the following button is not active anymore at the games pages. So sad. It would be a nice feature to use.

The following games feature will be functional to everyone again someday?

 
  TimmiluvsTimmiluvs

I went to 3 different LBs and the follow button is on all of them. I didn’t try and click it to make sure it’s functional (I don’t want to follow games) but I can confirm it’s there.

I believe there were issues with button being caught by adblockers before. If you truly don’t see the button in any LBs for a game, try disabling any browser addons you have to see if one of them is removing it.

 
  ShikenNuggetsShikenNuggets

Game themes do not apply to the page for adding or editing resources. The /edittool, /editsave, /editsplit, and /editpatch pages are all affected.

Edit: I've also just noticed that my user theme doesn't apply to the general Settings page (though, weirdly, it does apply to all the other ones, Notifications, Front Page, etc).

 
  daniloroxettedaniloroxette

thank you, Timmiluvs. It didn't occur to me remember disable adb this time. Now, it's fully functional. thanks

 
  RenusekRenusek

Uploading splits to a game's resources page gives me a following error: "That is the wrong file type. It must be a .zip, .7z, .rar, or .lss file.", but the file I am trying to upload, is in fact an .lss file.

edit: ah, I see, sorry then 😛

 
  RiekeltRiekelt

I have the feeling not all runs are shown on leaderboards, for whatever reason.

http:/​/​speedrun.​com/​ae2
I was checking Ape Escape 2's Leaderboards, and there were fewer any% runs than I remember, unproofed, and instead of 6+ runners, there are 4 All Monkeys runners, same for 100%. I did remember a certain runner and went to his profile.
https:/​/​www.​speedrun.​com/​user/​TOTOzigemm

If you go all the way down, you see he's 43th in Any% and 4th in 100%, yet he isn't on the boards.

 
  DaravaeDaravae

@RiekeltRiekelt Further inspecting the run, it looks like some key information was missing too when opening the run. When looking at the reviewed run without editing, I noticed the runners name, date of the run and name of the moderator were all not showing up.

I did manage to make it appear by changing the date to yesterday, to test. Since I noticed that the run in particular had a date of "30-11-2019". I think another user mentioned there is a bug with runs that have a date set in the future, but its strange because this run seems to be performed in 2016. No clue how that happened.

Either way, for some reason after that action, the date itself got adjusted too to the original date which was 08-10-2016 and the name of the runner and mod, as well as the date returned back too.

I'll do some testing on a test board and see if I can replicate what happened.

RiekeltRiekelt likes this. 
  BmanRulesYou21BmanRulesYou21

I believe its a bug with runs that dont have set dates, most of my old runs that dont have a date arent actually showing up on the respective leaderboards even though they are still tied to my profile.

 
  darGdarG

If a user donated the site and got banned, the text "Banned" and "Donated $X" will overlap.

https:/​/​imgur.​com/​a/​2MaUHfo

 
  VapoVapo

Currently every few hours the site logs me out and forces me to log back in. Logging back in requires email 2FA, and half the time this e-mail doesn't even send, forcing me to keep on trying until an e-mail actually does send (and even then sometimes it says the code is invalid).

 
  MLSTRMMLSTRM

Was submission date on runs always a mandatory field, and also has it changed recently in display behaviour for runs which do not have this populated, as some of the older legacy runs on the FF13 leaderboard recently went missing, and as far as we can tell the play date is the only thing that wasn't populated correctly on them.
We have now gone through and placed sufficiently old legacy dates on the runs we've been able to track down but it would be nice if we could get some correction applied across the board, or the restriction changed.

MrzwanzigMrzwanzig and BmanRulesYou21BmanRulesYou21 like this. 
  SloaTheDemonSloaTheDemon

so, on the Crosscode leaderboard the Current any% time is a 31 but it's showing the old 38 for me, everyone else sees the new PB but me. I'm not sure why that is. Just figured it would pop in and report this

 
  HabrenoHabreno

Played on date > Current date. Give it a bit and it'll show when it turns the 5th for whichever timezone the site uses (EST? I forget)

Edit: Yup, exactly the issue. It's there now.