Forums  /  The Site  /  Site Bugs
  SeydieSeydie

@RidiculousBox are you sure you made the categories underneath "Full-game categories"?
And hit save after?

 
  akaboomakaboom

WTF, guys, speedrun.com/games tab use 80-100% cpu. Try search game - cpu load 100% ~1 min, load page - cpu load 100% - few minutes. it only happens on speedrun.com/games

https://i.imgur.com/MbzconJ.png

 
  akaboomakaboom

Ok. I find problem and this Lastpass extension. Why is this happening? And how to fix it?

 
  blueYOSHIblueYOSHI

If it's an extension then it's an extension, SRC can't change anything about that. Maybe you could deactivate the extension on SRC?
I can't notice any difference between loading the games tab and basically any other site so I doubt it's actually the sites fault.

/edit: Maybe try Firefox? I heard it's a lot better performance wise

 
  akaboomakaboom

idk, i disable Lastpass and problem gone.
In Firefox same problem:
https://i.imgur.com/10iEYks.png
Scenario in the extension "Lastpass: Free Password Manager" slows down Firefox
I think problem whith Lastpass auto fill

 
  TalicZealotTalicZealot

Those autofills are usually sort of experimental so that is not surprising. They scan the dom tree of the page to figure out what could get filled. I imagine it can become extra buggy if a SPA loads a bit slowly while the crawl is happening.

ImaproshamanImaproshaman and blueYOSHIblueYOSHI like this. 
  xhadonxhadon

I don't know if it's been reported yet, but the website breaks down regularly. I last tried a Chrome version 73.0.3683.103 in guest mode.

In Firefox 66.0.2 I have the same problem.

How to reproduce the bug:
You open a page like "https://www.speedrun.com/ff8". There you click back and forth between the different categories. This is more likely if you switch between the different categories under "More...". At some point the CSS goes crazy and one of the following scenarios occurs:
1. navigation elements are on top of each other, it's hard to click something.
2. the page seems to repair itself, but in the DOM you can see the background moving 0.5 pixels to the left in a short interval.

I think in the second case a rule is applied which should be set if there is no background, because the background image disappears for a short time.

If the first case occurs, it is possible that the page still goes over to case 2. After case 2 I haven't found anything yet.

This can be observed everywhere on the website and not only at /ff8. There I could best recreate it (I tried it at /smo).

I hope this helps with the troubleshooting.

E: I just tried to reproduce it but it seems like this is fixed now.

starsmileystarsmiley likes this. 
  The_Retro_ChallengerThe_Retro_Challenger

Hello,
Noticed a few runs not appearing on the leaderboards. After submitting and approval, the tab does not display "empty" but when viewing said tab, it says "no runs available".
When viewing my personal runs, it's there, along with ranking etc...

 
  HowDenKingHowDenKing

@The_Retro_Challenger

are you sure your filter settings are set up properly for that leaderboard?
(check the variables if there's one or more set to "default" and uncheck those)

DaravaeDaravae and The_Retro_ChallengerThe_Retro_Challenger like this. 
  DarQ_MassacresDarQ_Massacres

unable to verify or reject any runs. I managed to verify 1 run today of the 60 I have pending. But now the site is crashing every time I hit verify or reject.

 
  ShikenNuggetsShikenNuggets

@DarQ_Massacres Is it the usual "check back later" thing or is it something else?

 
  DarQ_MassacresDarQ_Massacres

@ShikenNuggets The site crashes and says this "This page isn't working www.speedrun.com is currently unable to handle this request HTTP ERROR 500"
It isn't the try again message where the site loads but it loads weird, the site just crashes

 
  SwagsterSwagster

The site goes down constantly for me. Every time i try to click on a category for any game, it gives me an error message saying "ooops the site is under a lot of pressure right now, check back later." can anyone fix this or is this going to happen forever?

 
  ShikenNuggetsShikenNuggets

@Swagster Site staff are working hard to improve the server's performance, but unfortunately it's not a simple fix. Here's a post from an admin detailing a recent attempt to fix this issue, as well as some of the complications that arose from their solution: https://www.speedrun.com/The_Site/thread/laps4

DaravaeDaravae likes this. 
  BradenbestBradenbest

URLs seem to be case-sensitive. E.g. /Gyromite is fine, but /gyromite 404s. This is either a bug or an anti-feature. In either case, it should be fixed.

I know this site runs on nginx, so this solution should work: https://stackoverflow.com/a/18416699

 
  VikeMKVikeMK

It seems that a run of mine disappeared from runs awaiting verification under the "Pending actions" tab without being accepted, rejected, or deleted. I managed to find the run in my browser history though here which shows it still in a state awaiting. Here's the run: https://www.speedrun.com/mk8dx/run/m3opllqm

I spoke with a moderator of the game's board who said they can still see the run in their moderation queue, so the only issue is that it disappeared from the Pending actions page.

EDIT: The run has since been accepted, but will still leave the bug report here.

 
  RazorflameRazorflame

@Liv To further expand on this: Everything on that page, including pending games and rejected runs are NOT showing up on that page any longer.

afnannen136afnannen136, crewds and NihilistComedyHourNihilistComedyHour like this.