Forums  /  The Site  /  my account is very broken.
  HiHi
(edited: )

Quote

Since this is an issue affecting literally a single user

It's not just 1 account, there's probably dozens if not hundreds of accounts that encounter those issues. And even if it were just 1 account, after even Cam said that he shouldn't wait too long for it to get fixed and after he made a Support Hub ticket, it would be bullshit to not only not get fixed "soon" but to also make him lose his account because of being too late.

GarshGarsh, Merl_Merl_ and 2 others like this. 
  useruser

Quote

Since this is an issue affecting literally a single user

https://www.speedrun.com/the_site/thread/vqqbu/1#scudd
oh look, someone else having the same issues as me, what a surprise.

GarshGarsh, jackzfimljackzfiml and 4 others like this. 
  messages

Wow, someone else is having the same problem! I hope something is done about this soon.

GarshGarsh, jackzfimljackzfiml and 4 others like this. 
  messages

Wow, there are a lot aren’t there

 
  RaggedDanRaggedDan

Yes, it's an...
Interesting site structure

GarshGarsh, PearPear and 3 others like this. 
  useruser

there's so many more examples.
@knowledgebaseknowledgebase
@messagesmessages
@modhubmodhub
@..
and every account that ends in .jpg and .png, such as @ApolloApollo.jpg, @BenjiBenji.jpg, etc.
there's 22 accounts that have either .jpg or .png and their name according to the api, and probably close to a dozen more accounts that are broken. so i don't think there's just me who has this issue and i think the developers should hurry up before it's too late.

GarshGarsh, Merl_Merl_ and 3 others like this. 
  Act7Act7

what about @ForumsForums?

Oreo321Oreo321 and GarshGarsh like this. 
  GarshGarsh

Any account with a name that matches another page on the site is going to have this issue based on the url structure. It's not really clear to me what the best solution is. Maybe forcibly put an _ after their name in all urls pertaining to their user? I'm not sure what the logistics of that are though. It's certainly a preventable issue, there should have been some checks put in place to prevent these usernames from being used in the first place.

 
  useruser
(edited: )

Quote

there should have been some checks put in place to prevent these usernames from being used in the first place.

i made my account before elo even stepped in the scene, meaning even if they did add restrictions for these particular names that still wouldn't have solved the issue for me at least.
Quote

It's not really clear to me what the best solution is.

perhaps use the user's id to generate those links instead as those can't be broken (i think) and plus they aren't used anywhere else anyway, i don't even know why they track them.

 
  messages

They could just add the /user to the edit profile, edit theme, and settings. Currently I think my settings link is speedrun.com/messages/settings

MrMonshMrMonsh likes this.