Forums  /  The Site  /  my account is very broken.
  useruser

yesterday i logged into my account in almost 2 months to see what the site was up to nowadays. i noticed that a lot has changed since i've last took a closer look at it, so, as a normal person would do, i clicked on the "Edit Profile" button to see what was added. but instead of it taking me to the page where i'm supposed to change my stuff, it took me to https://speedrun.com/user/editprofile instead, which is the link to the username "editprofile".

this was.. very strange. i then tried to add a theme to my account. i clicked on the "Edit Theme" button and like previously, it took me to https://speedrun.com/user/edittheme, which again, is the link to the username "edittheme". when i tried to access my settings, same thing happened.

but i found a solution around this. if i instead use the normal link to edit my profile or my theme without using the buttons, and if i twist it a bit, i am able to now edit my profile and my theme. instead of using the link https://speedrun.com/user/edittheme (or editprofile), i am able to use https://speedrun.com/edittheme/user.

this solved the settings issue too, but there was another issue that i haven't found a solution to yet. i cannot access anything in the settings menu. editing the links to those settings doesn't work for some reason like it worked for editing theme, editing my profile or the settings. i really want one of the SRC moderators to see and respond to this thread because it's very annoying.

VyPrVyPr, GarshGarsh and 2 others like this. 
  useruser

i think i know why the system behaves the way it does with my account, but it should still be possible to fix.
the template for accessing any of the things mentioned above is https://speedrun.com/(your name)/(editprofile/edittheme/settings etc.), but since my username is literally "user", it overwrites the name portion with the "user" instruction used to view users instead.

 
  Oreo321Oreo321
(edited: )

In my case, the links to those action pages are:

Edit profile (no explicit username): https://speedrun.com/editprofile

Edit theme (similar to what you did): https://www.speedrun.com/edittheme/user/Oreo321
I guess in your case you should use the link: https://www.speedrun.com/edittheme/user/user

Settings (no explicit username): https://www.speedrun.com/settings

You say that your menu buttons redirect you to pages with different templates?
What happens if you use the links I wrote above?

Merl_Merl_ likes this. 
  useruser
(edited: )

okay so i logged out of my account and then logged back in and now i can access all of these that you mentioned using the buttons. but the problem of accessing anything in my settings is still present, as well as being able to see my pending actions, runs, or posts (info works somehow).

@Oreo321Oreo321 yes, the menu buttons in the settings (and pending actions etc.) redirect me to the user pages of these settings. for example, if i try to change my password and i press on the password button, it redirects me to https://speedrun.com/user/settings/password which shows that "User settings not found.", instead of putting me in the menu that is used to change your password. same thing applies for all the other buttons in the settings.

Merl_Merl_ likes this. 
  Oreo321Oreo321
(edited: )

After looking on all those links you mentioned, I see the problem.

Instead of using the template of "user/[user name]", those links use the bad template of "[user name]".

For example, your pending actions page is https://www.speedrun.com/user/pendingactions
instead of being https://www.speedrun.com/user/user/pendingactions

Or in the settings, your notification settings page is https://www.speedrun.com/user/settings/notifications
instead of being https://www.speedrun.com/user/user/settings/notifications

Because your username is "user" itself, those links are inherently broken and you can't do anything about it. You can't even change your username if you'd wanted, because that page doesn't work either!
Send a bug-report in the support hub, that's the only thing you can do at this point. Hopefully they can help you soon, otherwise you really are in a predicament here...

(Feel free to redirect to this thread as reference)

IvoryIvory, Merl_Merl_ and 2 others like this. 
  useruser

yeah that's the issue.
i made a bug report in support hub, hopefully they see it soon and fix it.

 
  HiHi

Hm that's very interesting. I got in touch with @IQIQ like a week ago and he told me how he couldn't change his theme at all (that got solved a few days ago though) but this is just next level stuff. Hopefully it gets solved soon and your account will act more normal than it currently does.

Merl_Merl_ likes this. 
  CamcorderCamcorder
(edited: )

Thanks for the detailed report. Just like in the other thread ( https://www.speedrun.com/the_site/thread/jd4ik ), we're aware of a few weird issues around profile and theme management for some users, and will fix them in relatively short order as part of a general cleanup effort. No ETA, but you shouldn't be waiting for too long.

PearPear, Oreo321Oreo321 and 3 others like this. 
  useruser

thanks.

 
  useruser

update: it's been 11 days and the issue hasn't been fixed yet.

 
  jackzfimljackzfiml
(edited: )

You should probably change your username. That would temporarily fix the issue imo.

 
  useruser
(edited: )

1. i can't change my username even if i wanted to because of the issue above (i can't access anything in the settings).
2. i don't want to change my username.

VyPrVyPr, 11 and 5 others like this. 
  useruser

shameless bump but it's been over 2 months since and there haven't been any changes to the situation. i almost lost my account yesterday because of not being able to change my email after i enabled email authentication, thankfully i realised before logging off.

O.D.W.O.D.W. and PearPear like this. 
  useruser

i understand that the team might be busy at work trying to improve upon the mod hub and other things but believe me when i say that i am at a dangerously high risk of losing my account purely because of website issues and i can't do anything about it. i've been getting more and more password reset requests recently, there are many people that want my account, and i can't change my password (which is weak), i can't enable email authentication and i can't change my email either. it would be unfortunate to lose an account especially when i literally can't do anything about it.

MrMonshMrMonsh, HiHi and 8 others like this. 
  GarshGarsh

Well this is unfortunate.

O.D.W.O.D.W. likes this. 
  QuivicoQuivico
(edited: )

Since this is an issue affecting literally a single user, I wouldn't be surprised if it's not at the top of the to-do list.

Edit: Disregard, you all below are right.

 
  WalgreyWalgrey

Aren't there users whose usernames also match the URLs of certain games on the site? (/iq comes to mind)
Aren't they encountering similar issues? Or something else?

MrMonshMrMonsh, QuivicoQuivico and 4 others like this. 
  PearPear

I was reminded of this account, which has a similar issue of their username messing up the site’s URL navigation. They’re inactive, but it’s just another example of how this aspect of the site needs to be adjusted.

https://www.speedrun.com/user/kermit.jpg/info

MrMonshMrMonsh, QuivicoQuivico and 3 others like this. 
  HiHi
(edited: )

Originally posted by Walgrey Aren't there users whose usernames also match the URLs of certain games on the site? (/iq comes to mind)

Originally posted by Hi Hm that's very interesting. I got in touch with @IQIQ like a week ago and he told me how he couldn't change his theme at all (that got solved a few days ago though) but this is just next level stuff.

Yeah those users such as knowledgebase and supporthub are also encountering those issues that @useruser is facing.