Forums  /  Streaming / Recording / Equipment  /  Help with Video Capture Device

Hello, for some time now I've streamed by using Window Capture with the Elgato device's native software, and using Desktop Audio to pick up game audio. This has the undesired effect of bleeding over onto my mic, so I was recently suggested to start using Video Capture Device instead.

This works a wonder for PS3 and PC. I can capture the game and all audio goes only to OBS, not to my streaming PC's speakers, so there's no bleedover onto my mic.

PS4 is another story. The Elgato simply refuses to work when I try this with PS4. The only thing it ever shows is "No signal" despite the fact that if I deactivate or remove the Video Capture Device from OBS, everything goes back to working fine. It shows up on my TV perfectly.

It is not HDCP. That causes a different problem I would recognize (essentially, it makes the signal "stutter," giving a frame or two every 10 seconds, say - the problem here is there is no signal whatsoever). Regardless, I can guarantee HDCP is turned off.

This is my setup just completely dying. If I run the Elgato software as normal, without a Video Capture Device in OBS, everything is fine again. I have picture and sound on my TV, and on my streaming PC. But it would bleed onto my mic, so that's not a possible solution. But activating the Video Capture Device makes everything stop.

Can anyone help?


My TV can display 1080p. I've tried setting the PS4 to force that output resolution, that didn't change anything.


Just to confirm, you're not running Elgato's Game Capture at the same time as trying to Video Capture Device in OBS correct? If you attempt to capture in OBS while Elgato's native program is running, it priorities the signal to the native Game Capture, not the Video Capture Device in OBS.

I recall recent models of Elgato needing a USB3.0 connection to function properly, and as someone who went though quite the ordeal in updating and reinstalling 3.0 drivers, that's my first suspected area for why the PS4 would stutter (I never used my Elgato for PS3 though, so I cannot confirm)


Correct, only OBS is open. If both are open, that causes a different error "This device is in use by another application"

If I was unclear, the PS4 signal does not stutter. There is no signal. It just says "No signal." If I deactivate the Video Capture Device in OBS, everything is fine. The output to my TV is 100% fine. And when it's on, neither my TV nor PC have signal. PS3 and PC (I use a two-PC setup) both work fine without any problems.


Only other things I can think to try is:
- In properties of Elgato in OBS, toggle the source input to something else, then toggle it back
- In same place as above, Disable/Enable device to reset it
- In Device Manager, disable and reenable drivers

Sorry if I can't be of further help

(edited: )


- In properties of Elgato in OBS, toggle the source input to something else, then toggle it back

😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂 😃 🙂


It's all smiles here. THANK YOU ❤️

TokuHer0TokuHer0 likes this.