Forums  /  Super Mario series  /  Super Mario Bros.  /  Milliseconds
  burgerlands2burgerlands2

So I submitted a 5:04 yesterday and the mod who verified it added the milliseconds to the time, presumably because it was easy to do so since I was using the auto timer script. But the rest of the 5:04's (and the 5:03's and most other times for that matter) do not have milliseconds. The result is that the rest of the 5:04's are all tied, but then mine is sitting on its own at a worse position even though there's the possibility that it's faster than at least one of those other 5:04's.

I'm not going to bother arguing a bunch about this because I don't personally care about the difference between 70th and 74th place. But I just want to bring this up once because it's actually stupid to have one random time with milliseconds on it when the rest at that level are all rounded to the nearest second. Rounding things to the second and calling them "tied" is imprecise but still a perfectly correct way of ranking things. However, rounding some times to the second and some to the millisecond allows for literally incorrect rankings (e.g. a 5:04.999 is submitted as a 5:04 with no milliseconds and a 5:04.001 is submitted with milliseconds and so the 5:04.001 is ranked as a slower run on the board). Inconsistent rounding is nonsensical, especially for a leaderboard this dense; there should be a written policy of "things < X time all have milliseconds, things >= X time all don't have milliseconds".

eddiecatgamingeddiecatgaming and JumpyluffJumpyluff like this. 
  mav6771mav6771

Sorry, issue fixed after I was notified.

After doing a ton of these I mix up cutoffs in certain games and categories, thus I thought the cutoff was 5:05 instead of 5:03.

Again, sorry, and the issue has been fixed.

 
  burgerlands2burgerlands2

Cool, no worries, good to know for sure that you do already implement a cutoff (since I don't see it written in rules)

mav6771mav6771 likes this. 
  burgerlands2burgerlands2

There's also a random 5:57 with milliseconds as long as I've brought the topic up anyway :thinking:

 
  atari2.0atari2.0

What auto splitter did you use? My livesplit says that there is no autosplitter for smb1

 
  burgerlands2burgerlands2

Yeah if you look in Resources, there's "automatic timer" by Hubcapp at the top, for fceux. That's what I used. It embeds a timer and splits directly in fceux, it's not a livesplit thing.

 
  atari2.0atari2.0

Oh ok thanks, I use BizHawk normally so I didn't know that, thanks for the info

 
  zdoroviy_antonyzdoroviy_antony

There is no milliseconds at 5:03 or slower runs, because it is too big work for moderators to time every run so precisely.