Forums  /  Space Invaders 1999  /  Emulator run requirements
  TransparentBlueTransparentBlue

As of right now emulator runs are allowed for any category provided that they conform to the following rules, those are not retroactive so any runs already present that violates any of those rule will be kept.
Some of those rules might be overlooked at the moderators discretion for any run below the top 3 or not within a certain time of the current world record.
If you have trouble understanding some of the rules please contact me @TransparentBlueTransparentBlue and I'll clarify for you.
If you have trouble with your emulation setup at all please contact me @TransparentBlueTransparentBlue on the community Discord server ( https:/​/​discord.​gg/​tw4vFGv ).

> For All platforms

Exempt from any of the the following is PCem, Wine, graphic wrapper (i.e. dgVoodoo, WineD3D etc) and Virtual Machine to run the PC version on modern systems, if you use those just include the fact that you did use that and the host / guest systems (i.e. running an XP VM on Windows 10 would mean that Win 10 is the host while XP is the guest) or the name and version of your wrapper in the submission text.
You include the windows border in the video
You include the exact emulator version or build with your submission
You include the configuration files you used with your submission
You have a FPS readout onscreen at all times during the run
You must, if using a Retroarch core, show the core and latency options after you complete your run, to note that overclocking of any kind is disallowed as it has been shown to make the game unstable and make some things act in unintended ways, CD read speed is allowed for now as it doesn't impact IGT, runahead is allowed for now as it cannot reduce the input lag below console level.

> For the PS1 version

> Following emulator are explicitly banned
>PCSX / -df / -R /-R PGXP / -ReARMed etc, any version
>ePSXe, any version
>Avocado, will be reevaluated once it's more complete
>No$PSX
>pSX / pSX-fin
>PSXACT, will be reevaluated once it's more complete
>hpsx64, will be reevaluated once it's more complete
>Rustation, will be reevaluated once it's more complete
>Bleem!
>SSSPSX
>PCSX2
>PSXeven
>Emurayden
>Connectix VGS
>WiiSX
>POPS, only the PS2 version
>Bleemcast
>FPse
>Bizhawk

> Following emulator are explicitly allowed
>Mednafen, any version past 0.94, launcher used irrelevant
>BeetlePSX, excluding the HW version
>XEBRA, most recent version as long as plugins aren't used.
>POPS, PSP / PSVita / PSTV / PS3 versions

If whatever emulator you're using is not mentioned here bring it up and someone will look into putting it here (probably in the not allowed list though so be aware of that)

> For the N64 version

Runs using N64 emulation are not allowed for now.
Simple explanation is that both of the current major emulator have noticeable issue with that game and I'm not dealing with that.
If you find an emulator that can play the game without massive sound popping (PJ64) or audio desync (M64p), please mention it to me and I'll be sure to add it here.
And the other emulators are not worth mentioning.
Currently being reconsidered, please contact me @TransparentBlueTransparentBlue for clarifications.

> For the GBA version

> Following emulator are explicitly banned
>VBA / -M / GX etc, any and all version
>iDeaS
>GBE+, will be reevaluated once it's more complete
>MAME
>Meteor
>Nanoboy Advance
>NO$GBA
>FatGBA
>BoyCottAdvance
>PlayBoy Advance
>My Boy!
>GBA.emu
>gpSP
>TempGBA4PSP
>Bizhawk

> Following emulator are explicitly allowed
>mGBA , preferably most recent version but anything above 0.6 should be good, include the libretro core version if using Retroarch, must use a BIOS image and prove you do by resetting at the end of a run to show the GBA boot animation.
>Higan, most recent version only.

If whatever emulator you're using is not mentioned here bring it up and someone will look into putting it here (probably in the not allowed list though so be aware of that)

>For GB

Since someone has went out of his way to make a proper speedrunning emulator for that platform all run must be done on GambatteSpeedrun with a GBC bios image, no exception.

IvanzypherIvanzypher likes this. 
  IvanzypherIvanzypher

I wish I knew what made the 64 emulation tick. This game is not that complex and project 64 still has issues with the black boxes. I'm happy I found the game when i did,This game could use more attention. Emulation is probably only good for "at this point in time" maybe just testing if their are any more major issues that can occur between versions.