Goof Troop Forum  /  Emulators?
  TheLetterSeventeenTheLetterSeventeen

I'm going to start officially running this game, so I'm wondering if there is a specific emulator you want me/us to use.

 
  LeHulkLeHulk

For SNES emulators, we generally accept:
- Snes9x version 1.51 or higher
- SNESGT
- BSNES/Higan/BizHawk.
Have fun running!

ChachamaxxChachamaxx, LysergoLysergo and 2 others like this. 
Latest News
View all
No news
Recent Threads
View all
Thread Author
JP Easy mode
Last post
jymotionjymotion
7 replies
Linux emulators
Last post
BodaoBodao
2 replies
Goof Troop Co-op Tournament 2020
Last post
DunkelGotikDunkelGotik
0 replies
Emulators?
Last post
TheLetterSeventeenTheLetterSeventeen
2 replies
Run is missing on the board?
Last post
junkyard_davejunkyard_dave
6 replies