Forums  /  Dino Crisis 2  /  PC version menu problem
  [user deleted]

Hello everyone! I have this problem with my pc version idk why, it was fine i did a couple of runs in this version i leave it for a while and then just rip, game starts but instead of showing the menu to start the game it auto skips to the demo scene, i can skip it but it happens the same thing over and over and over again.
I already tried reinstall, admin rights (all compatibilities) but it didn´t worked.


I had the same problem, I tried to reinstall too but nothing changed... 😕
If someone can find a solution...
BTW I asked someone in Japan to find me a DC2 Sourcenext version, I'd like to try it. Seems to be so much better than PC !! That version is pretty hard to find.


lol, is there a sourcenext version of the game? 😮


yes but very hard to find (I tried since many years...)

  [user deleted]

I tried to find sourcenext too but like you said, it´s really hard. And btw it´s fixed, it´s weird, i uninstall the game about a month ago because i coudn´t find a solution and yesterday just reinstall it and it worked again...i hope never happens again.


I just found Unopened Sourcenext PC version. 4,000 Yen. Ill buy in 1 week 😉 Hope still be in shop. PogChamp


Updates on the sourcenext version? I'm also getting the same problem but reinstalling doesn't fix anything for me.

EDIT: Found a fix, I used Rivatuner D3Doverrider and forced VSync.


Reviving the old thread but I've used the Rivatuner D3Doverrider, forcing VSync and triple buffering and that kiiinda fixed my input problem, I can sometimes start the game (Mashing enter hoping I can start the game, it doesn't even show the start/load/options menu), but I'm getting very low FPS, making the game unplayable. Does someone know if this is solvable, and how?