Glitch & Trick Research/Discoveries
A Hat in Time Forums
Glitch & Trick Research/Discoveries
Ontario, Canada

Hey there guys! I figured I'd make a thread for glitch/trick finding seeing how there wasn't one. I mainly made this for people who don't use the discord server or just want their stuff to be publicly seen. To start off the thread:


Added Emps video of getting on top of Dead Bird Studio to skip half of it. It seems he found it first so it's only fair to put his video here instead of mine :)

Edited by the author 5 years ago
Mungaru and kyo like this
New York, USA
She/Her, They/Them
5 years ago

New Jersey, USA

Recording some odd things i've found here and there

and just in case, early snatcher hits from yesterday

Edited by the author 5 years ago
Ontario, Canada

I thought I would try out empulent's DBS OoB but in the awards ceremony to see what it was like past the inaccessible area. It's completely useless of course but I thought I would post this for documentation purposes. DJ Grooves is still left in the level, but he's shouting at non-existent penguins.....creepy. You can also still rack up your bill which is weird. It doesn't carry over to the warehouse part of the level though.

Pays de la Loire, France

I had a bouton press glitch at the end of the run just after an update of the game Is it a particular case or is it going to be permanent ? -_-

Texas, USA

Saviiator That skip was patched in the update, you have to press all of the buttons to use the telescope or use an older patch

Pays de la Loire, France

I've done it, thank you

Edited by the author 5 years ago
Washington, USA

Found a way to clip out of this part in Contractual Obligations (happens around 2:10 in the video). Haven't gotten further than this in the game so I don't know if it's useful, but you can explore the entire next area as well as slide past the fire walls in some corners. Don't think any cutscene triggers load like this, since I looped around the whole area and only triggered a short cutscene when I entered subcon forest.

Basically if you have the no-bonk badge and dive into a sloped surface that you can't climb up, you can carry your momentum until something stops you. As per usual, if you get stuck in the sliding animation it'll teleport you back to your last standing point. In this case, it warps you out of the contract room. The particular setup I've had success with is to jump off the contract, then wall-climb, jump off, double jump back into the wall, and then dive.

Edited by the author 5 years ago

Here are some small things I found :

First, it is possible to skip the beginning of Conductor's epilogue version of the studios, simply by walking in a hole lacking collisions. You can also walk to the left from that hole but I didn't find anything interesting there (and it's kind of easy to fall outside of the death barrier thus softlocking the game)

As shown in the video, if an item disappears while Kid's holding it she will get stuck carrying an invisible item. For some reason she can double jump in that state, and even attack with her umbrella (not at first, probably after triggering some animation first). Most likely useless though.

I was messing around in the hub stage in a save before 25 time pieces in version 1.0, and I found this glitch spot. Walk into the wall at the right angle, and hold the hat select down, and hat kid will rise up. However, it seems like the game still knows you're on the ground, so the walls will still get in your way. Figured it might be worth sharing anyway, though. Maybe there's a way to get around it, but I don't see it.

It's surprisingly easy to do but still pretty weird, as it makes Kid ignore ceilings while keeping collisions with walls. I couldn't find a way to go over the main room's walls either, despite letting Kid go upwards for half an hour. Furthermore, even if we could make our way into the attic, there is no telescope here or anywhere else inside the spaceship, as they only load once you get enough time pieces and activate the corresponding room. The only thing that's loaded inside the ship are the two time rifts, so maybe it could lead to accessing them early but I don't think we could get anything more.

United States

Just ran into a really strange glitch on my first playthrough. I was just talking to some mafia members at the start of the game, and suddenly I could no longer jump. the dust effect still appeared when I tried to jump, but no height. If I walked off of a ledge I would then float at the same height I was previously at. I could still dive and double jump while floating, but I never gained any height. I could definitely fly around as much as I wanted though, although I did sink very slowly while flying. When on the ground gameplay was normal, other than not being able to jump.

Not sure how helpful or how to reproduce the effect, but I did a little searching and couldn't find anyone talking about this particular glitch, so I figured I'd mention it. Unfortunately it fixed itself before I could get any footage.


I just glitched out the final boss by throwing a potion/bomb while triggering the dialog. I've been trying to reproduce it for about an hour now but to no avail.

Moustache Girl would stay on her throne but she'd simultaneously spawn at the foot of the pile of time pieces and be standing completely still and be able to take damage. I think I beat all of her phases and then the game soft locked forcing me to exit to hub.

No idea if it could make the final boss quicker until I'm able to reproduce it reliably. Anyone else tried something similar?

I also managed to make her disappear from the 2nd phase for another soft lock where I had to exit to hub. No idea how that happened and it certainly wasn't useful.

New Mexico, USA

Hi all. First post, I just signed up to share this glitch; It's the same one @Asmodemus discusses a couple posts earlier. I managed to capture it with my PS4 and upload it. I'm still working on being able to reproduce it, but it seems like the glitch is triggered when you're falling off a platform and the game is trying to subtract from your Z coordinates while you simultaneously are jumping and adding to the Z coord.

The really interesting part is that unlike Asmodemus's experience, I was able to use this to create an infinite jump loop by hammering on the X button. The very slow sinking seems like it might be the game trying to run the code for the badge that prevents death falls, but alas I did not think to take the badge off and see if I could get more speed-run friendly descent speeds.

The glitch was eventually remedied by interacting with a chest. It does not, however, stop when you pick up yarn, badges, vault tickets, pon or health. I'm assuming that the 'fix' is in any cutscene where the game has an excuse to fix the player position to a certain coordinate and set values like x/y/z speed or Jumping/Doublejump to 0.

I think being able to reproduce this might be the ticket to a viable and visually interesting 100% category.

United States

Hi there @PeezyKreezy

The glitch you performed is what's known as a Pattycake Hover. It's a result of ledgegrabbing then vaulting while in invincibility frames after being punched by any of the Pattycake Mafia. Besides looking cool, the only main purpose it serves is allowing you to collect an ice yarn which is floating on a hot air balloon early, which is nice in Bingo (and perhaps the unspoken All Collectibles).

PeezyKreezy likes this