Forums  /  The Site  /  Site Bugs
  PackSciencesPackSciences

" i never received any notification when my last run was verified" I have the same problem

 
  DelnDeln

yeah the notifications tab doesnt show anything at all anymore.

 
  kirkqkirkq

Notifications should be fixed (at least for the most part?) Let us know if there are still issues.

 
  PackSciencesPackSciences

No, there aren't any issues, just a lot of late notifications.

 
  BmanRulesYou21BmanRulesYou21

the user who created a forum post, on the overview of topics is off center,

 
  LyseriaLyseria

Hey everyone,

I have this bug when i want to verify / see a run with split.io since this morning 🙁

"Fatal error: Call to a member function getSplits() on a non-object in /home/speedrun/src/Run.php on line 832"

 
  mugg1991mugg1991

on my profile http://www.speedrun.com/user/mugg1991 it says I have 5th at melee classic normal.
But on the leaderboard page http://www.speedrun.com/ssbm#Classic_-_Normal I'm 4th.

 
  CryZeCryZe

That's because the default view for SSBM is banning emulators, while the normal leaderboard doesn't. On the normal leaderboard you are 5th.
Looks like both the API and the Profile are forgetting to include the "Emulators: Hidden by default" setting.

Seems like SM64 has a similar problem, but there it seems to be hardcoded into the code, where the leaderboard is automatically filtering away Virtual Console runs, but not in the API or on the Profile page.

 
  JumpyluffJumpyluff

I'm trying to change the abbreviation of speedrun.com/iwbtzg to speedrun.com/iwbtzerogame so that it matches the format of the rest of the abbreviations of the series, but I'm getting an error, it's been happening for weeks. Can somebody figure out why this is a problem for this specific game?

 
  Lighnat0rLighnat0r

Yeah, the place calculation on everywhere except game leaderboards misses a couple of settings atm. The problem is that with all the different possible settings, calculating the place is a real mess if you don't just calculate the whole leaderboard (which in turn is too slow to do instead).
SM64 is all kinds of special bad, since it hardcoded preselects N64 for the platform.

Jumpyluff: Fixed.

 
  ShadowLinkyShadowLinky

When submitting a run that has milliseconds, something goes wrong.
When submitting 6.04 ( see screenshot ), it will change the 6.040 to 6.40, thus making the PB obsolete in this case, not updating my time ( see second screenshot ).
Same issue is happening for other runner who has a 6.06.
Filling in 06 or 060 has the same effect.

Not sure how it didn't happen for the runner with a 6.09, might be because it was his first submitted run for that level leaderboard.
Editing the current PB with the new time doesn't work either.
Assuming the site gets confused when there's 2 zeros in a run with milliseconds if it's not first submitted run.

Screenshots:
http://i.imgur.com/YHTJBq8.png
http://i.imgur.com/NDHloPH.png

Thanks in advance.

 
  PackSciencesPackSciences

Are you sure if you fill with 3 digits it doesn't work ? Because it should work by filling 3 digits.
Also Lightnator did a recent update with digits so it might have caused that.

 
  Lighnat0rLighnat0r

ShadowLinky: Thanks for reporting that, fixed.

 
  Spec3xSpec3x

Is there a glitch where runners can verify their runs without being moderators?

http://www.speedrun.com/muppets

http://i.imgur.com/34Uzwai.png

 
  PackSciencesPackSciences

You have to set "Runs require verification" in the game settings.
Else, anyone can set any time without verification before the run is posted

 
  stumpstump

I just noticed a couple of character encoding issues in notification emails.

I moderate Pokémon TCG, and new-run-to-verify notification emails have just a (quoted-printable'd) 0xe9 byte for the "é" in the body, despite the body claiming to be UTF-8. My MUA shows a replacement character because this is invalid UTF-8 (should be 0xc3 0xa9). This occurs in both the text/plain and text/html parts of the email. (The copyright symbol later in the text/plain part of the email ¤is¤ properly encoded and displays correctly.)

The character also gets replaced with "\xE9" (those literal four characters) in the subject header. I'll bet the reason for that is related.

If this is happening for other games too, I imagine this might be a great annoyance for ones with a larger number of non-ASCII characters in their names.

 
  mugg1991mugg1991

http://www.speedrun.com/sml2#Any_Glitchless

Oh_DeeR's previous runs where on emu, and then on GBC.
GBC was the only system available on this leaderboard.
Now I verified his newest run (26:49.😎 and accepted it.
Then I added a new system SGB, and edited his run to have that system.

Then a bug occured: His previous time showed up on the leaderboard alongside with his newest time, even though the setting was "exact players 1".
I have manually edited the obsolete time and unchecked "auto verify run" but then his older time before that showed up, etc.

As I unverified all his obsolete times one after the other, they showed up on the "awaiting verification" list.
I rejected them all so now his newest time is the only one on the leaderboard.

 
  Lighnat0rLighnat0r

mugg1991: If you want runs on different platforms to obsolete eachother, you should enable 'Platforms obsolete eachother' on the edit game page.