Forums  /  The Site  /  Site Bugs
  AhramanyuAhramanyu

I am having the problem that the FF8 leaderboard isn't separating the runs anymore by category. I added 2 runs recently, and also a new variable, but aside from that, no manual changes.

http://www.speedrun.com/ffviii

 
  Lighnat0rLighnat0r

Yeah that was a thing affecting all game pages, which has since been fixed.

 
  Skull64Skull64

I'm seeing a bug where the EU flag isn't shown for PAL runs. Seems to be affecting all games.

 
  PresJPolkPresJPolk

I want to replace the placeholder Legend of Zelda background I put in.

I go to Edit Theme, I delete the current image and save. Great. it's gone. I then hit the button, pick the new file, and save... and the old image comes back.

 
  GyooGyoo

Make sure you ctrl+F5 the page so it clears the cache.

 
  PresJPolkPresJPolk

OK so that's the bug then. When the image changes it needs to bust the cache.

 
  GyooGyoo

Well the cache is managed client-side, it's above my knowledge to know if the server can force the cache removal or not.

 
  PresJPolkPresJPolk

The cache is managed client-side based on information given by the server.

At the very least the server should be using a new filename for a new image.

 
  CubicalSucroseCubicalSucrose

The API seems inconsistent for partial names. For example:
http://www.speedrun.com/api_records.php?game=xa&amount=9
Returns the Faxanadu times when submitting just two letters in the name. "yi" works for Yoshi's Island, so some abbreviations seem to work.
However:
http://www.speedrun.com/api_records.php?game=fa&amount=9
Returns null. Same with "ad" and "du" (although "adu" returns times).

 
  kirkqkirkq

My guess is it just returns the top match. YI matches because that's the abbreviation listed for the game. "xa" just looks like you got lucky and it happens to be the highest match. It seems like it does exactly what the search bar does, so I don't think it appears "inconsistent". Note: "fa" pulls up too many series and no games, which could theoretically be improved?, but why not just look up an actually meaningful and reliable string.

 
  Ihavenoname248Ihavenoname248

Game pages are case sensitive. I'm not sure how simple that would be to fix/implement case insensitivity, but it's somewhat annoying.

 
  WilliamBarrowsWilliamBarrows

The Resources interface won't let me upload .zip or .rar files. It gives me the error "That is the wrong file type (application/octet-stream). It must be a .zip or a .rar."

I'm using Chromium browser, and my zip/rar files were created with winrar.

 
  Lighnat0rLighnat0r

Some videos autoplaying even though they've been set not to on our end is an issue on Twitch's side which has been reported to them but they haven't fixed it (yet?).

EDIT: Yes. this only affects twitch videos that have /v/ in their url, those are the ones broken.
Link to the bug report (just in case anyone is interested) here: https://github.com/justintv/Twitch-API/issues/289
As you can see it's been broken since december but still not fixed by them.

 
  kirkqkirkq

This might have to do with the fact that his Twitch video url has a /v/ and all the others in that thread seem to have a /c/ I don't really know enough about Twitch embedding to comment any further. That difference could just be pure coincidence.

 
  mobiusmanmobiusman

I should have known it was twitch's fault!

 
  TheguesstTheguesst

The strider 2014 submission page seems to be broken. Users can submit runs but get errors doing so. errors such as: "Warning:Recevied more than one row. Use query() if you intend to fetch multiple rows. in /home/speedrun/src/Database.php on line 58" appear and the run never appears in the mod verify queue. Can someone look into this?

 
  kirkqkirkq

You had two blank individual level categories, I'm not sure how exactly. I changed it to one with a name. I'm kind of afraid to delete the single category as I'm not sure what happens if I do that. My quick test worked, if there's any more issue let us know.

Ideally the site should catch the error. Although this might be left over from some of the past changes and the game just never got updated.

 
  Lighnat0rLighnat0r

Originally posted by kirkq Ideally the site should catch the error. Although this might be left over from some of the past changes and the game just never got updated.

Yeah, adding categories without names will return an error since about a month ago, this was probably left over from before that.

Originally posted by Sceezy I don't know why but the leaderboard isn't showing the time

Img: http://tinypic.com/r/2v9rasx/8


Fixed, thanks for reporting.

 
  huxxnyhuxxny

The Mario Kart 8 Leaderboards ranking and the users ranking on their profile page doesn't not match... also, i never received any notification when my last run was verified... its nothing major, but its the only game that seems to have this problem so far... ;D