Forum posts

Forum: The Site

Thread: Ability to submit 0sec runs on Ingame Time

Started by: _SS_SS

The issue is based on how the site treats 0 values as null values. Not an easy fix, certainly.

I'm sure the game mods for categories/games that can have legitimate 0second runs might be better off finding a creative workaround for now, one that suits the game as much as possible.

 

Forum: OVERWHELM

Thread: Rules for runs

Started by: SkelteonSkelteon

There might be a way to tunnel online with third-party software. I haven't done that in years though, not sure if it's any good yet.

 

Forum: The Site

Thread: New site layout - Amendments #2

Started by: PacPac

I have the exact same issue.
I don't want milliseconds displayed for runs that are only precise to the centisecond.

But it's been that way for years.

Hopefully now that the ui has changed and the board settings page is a lot more expandable, we will see changes like this in the future.

merpellmerpell likes this. 

Forum: The Site

Thread: Feedback thread

Started by: PacPac

@LivLiv

Originally posted by LivSince you state all runs should have milliseconds

I did not state that. I'm afraid you may have misinterpreted the first line of my post.
I don't disagree with what you're saying in response to how you interpreted my statement though. We are on the same page.
With my suggestion, a runner can choose to input ms even if the game doesn't visibly track ms, or even if the run tracks only tenths of a second. Or they can choose not to if it's not required.

@HowDenKingHowDenKing

Originally posted by howdenkingThe main issue I have with that is that a 5:54 would still be treated as a 5:54.000 by the site

Well no, that's the whole point of my suggestion. As I said,
"If the board is set to centiseconds (truncated), the time of the run is treated as 12:34.56.
If the board is set to centiseconds (rounded), the time of the run is treated as 12:34.57."

The potential problem you pointed out, (where a runner can omit ms), is not a problem unless the board switches timing rules and decides to start tracking milliseconds. So that's a pretty exceptional situation but not unheard of. The thing is... that problem ALREADY exists as things are now. If a board that doesn't track ms (or tenths or hundredths) switches from seconds to partial seconds, everyone gets set to .0 or .00 or .000.
With my suggestion, the conversion work is already done for those who already submitted their accurate ms times.
It would be the mod's job to retime runs with the current setup, as it would be with the proposed setup. This is not more work for the mod. It is equal or less work for the mod.

I thank you both for the responses.

ImaproshamanImaproshaman likes this. 

Forum: The Site

Thread: New site layout - Amendments #2

Started by: PacPac

https:/​/​imgur.​com/​hftwa9L

The tab for "misc" is overlapping the lower border for Any%.

This is on mobile, chrome browser, Titan Souls game.

ImaproshamanImaproshaman likes this. 

Forum: OVERWHELM

Thread: Rules for runs

Started by: SkelteonSkelteon

WOOHOO everything is awesome now!

1. The timer does not pause when you pause the game.
2. The split does not reoccur when you complete the same objective twice (i.e. starting a boss fight split, dying, starting the fight again).

 

Forum: OVERWHELM

Thread: Rules for runs

Started by: SkelteonSkelteon

https:/​/​twitter.​com/​randomnine/​status/​1151890142078078976

Update is being pushed to PC. I'll check later today what has changed.
With coop we might need to reorganize some of the categories anyway but that remains to be seen.

 

Forum: The Site

Thread: Feedback thread

Started by: PacPac

I think run submissions should always allow millisecond input. All runs should have millisecond data even if it's invisible.
The game settings should then dictate what level of precision is tracked on the board.

Example:
A runner can enter 12min34sec567ms in a submission, regardless of the degree of precision by which the times are tracked.

If the board is set to centiseconds (truncated), the time of the run is treated as 12:34.56.
If the board is set to centiseconds (rounded), the time of the run is treated as 12:34.57
If the board is set to seconds, it'll be 12:34. (Rounded seconds is 12:35 but I'm not sure if any board should be rounding up seconds. There's probably a few exceptions.)

That way if the mods decide to change the board/category settings later, the data of the run allows it to auto convert to the new timing rules of the board/category.

goadirothgoadiroth, ShikenNuggetsShikenNuggets and 2 others like this. 

Forum: The Site

Thread: New site layout - Amendments #2

Started by: PacPac

Scratch my last suggestion.
Why is there even a direct link from the topbar to edit your profile theme at all? It's not the kind of oft-visited menu option that needs to be accessed from anywhere on the site. It should probably be relegated to a subsetting under Edit Profile.

I think you should consider cutting the topbar user icon/name dropdown down to View Profile; Edit Profile, Site Settings, Mode switch; Log out.

The little palette icon is cute tho.

Sorry to devote much text to such small points, I think they will reduce confusion over the long term.

ImaproshamanImaproshaman likes this. 

Forum: The Site

Thread: New site layout - Amendments #2

Started by: PacPac

@emeraldalyemeraldaly and those who liked your post...
As Pac said in the original post (and edit: in a later post on page 2), this is completely intentional.
To reiterate... With the latest amendment, your site-browsing theme became the one called "Default", which you can change in your settings under the General tab. Unless I'm mistaken, this is a different shade of emerald green than the original much-maligned hue. The forums use the site-browsing theme. Your profile uses your profile theme. (Except on the general settings page, which uses your Site theme so that you can preview it when you change it.)

This is really a huge change.
Previously there was no way to differentiate how you want your profile to look and how you want to browse the site. Before this amendment, if you wanted a coral pink profile to match your online brand, you were stuck with coral-pink everything across the whole site. It was imo an absolutely necessary change, thank you Pac.

All that being said... The theme switch does look odd when you switch tabs under your settings from General to something else. I'm not sure if this hybrid approach is great, given the confusion it immediately caused.

Maybe the Settings page should use the site theme, for all tabs. Your site settings are separate from your profile, after all, and probably shouldn't use your profile theme.

Also, it seems that people are mistakenly assuming (understandably) that the "Edit theme" button will allow them to change the site theme. Maybe rename "edit theme" to "edit profile theme"?

ImaproshamanImaproshaman likes this. 

Forum: The Site

Thread: Can't change profile background

Started by: IcoIco

It was also reported here
https:/​/​www.​speedrun.​com/​post/​5lklt

Seems to be an issue. Hopefully it won't be long!

ImaproshamanImaproshaman and IcoIco like this. 

Forum: The Site

Thread: New site layout - Amendments #2

Started by: PacPac

Bug on mobile browser, not sure if it's related to the new UI.
youtube.com/watch?v=4XBsJhIIns4

 

Forum: The Site

Thread: New site layout - Amendments #2

Started by: PacPac

Very glad to see the time and thought put into amendments is clearly paying off now. Many will be happy to hear about these latest reverts and improvements.

FIXED!! Visual bug to report:
I'm on mobile, browsing the site with the default dark mode theme (green and charcoal).
However, my mobile browser is still trying to use the colours from my profile theme (blue).
As a result, I have a blue browser bar adjacent to a green topbar. Doesn't look great.

Screenshots:
https:/​/​imgur.​com/​pTOn9EH normal browser bar colour, in day mode.
https:/​/​imgur.​com/​sKJjGkb dark mode enabled, browser bar is suddenly blue even with "default" site theme.

ImaproshamanImaproshaman likes this. 

Forum: The Site

Thread: Game Addition still broken?

Started by: VettisVettis

It's fixed now.

 

Forum: The Site

Thread: Deleting Developers

Started by: DiamondcrafterADiamondcrafterA

I tried it. I think this bug applies to all tags not just developer.

ImaproshamanImaproshaman likes this. 

Forum: The Site

Thread: Game Addition still broken?

Started by: VettisVettis

Over 3 weeks so far since game addition was stopped. I'm surprised how well everyone is handling it! 👌

 

Forum: The Site

Thread: New site layout - Amendments #1

Started by: PacPac

Hey so can we have custom themes back?

 

Forum: The Site

Thread: Report a site bug

Started by: ZephilesZephiles

^
The first bug you mentioned is definitely not leaderboard-specific.
All non-zip and non-rar files have been disabled on every Resources page no matter what leaderboard.
(This is notwithstanding the fact that the resources page still incorrectly say that multiple different filetypes are allowed.)

 

Forum: The Site

Thread: New site layout - Amendments #1

Started by: PacPac

It's still a bug tho.

ImaproshamanImaproshaman and HowDenKingHowDenKing like this.